blob: 39fe4b9b7a8be441901fe2e8d21f389a505577e4 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Sensors plugin for the Xfce Panel"
2HOMEPAGE = "http://goodies.xfce.org/projects/panel-plugins/xfce4-sensors-plugin"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b94789bed9aec03b9656a9cc5398c706"
5
6inherit xfce-panel-plugin
7
Andrew Geissler72956ed2021-01-08 16:11:14 -06008SRC_URI[sha256sum] = "83c64ae4618dd592971cfa0bc285a9b47af801a3ed856835cdb2a4c533c7846c"
9SRC_URI += "file://0001-Do-not-check-for-sys-class-power_supply-we-are-cross.patch"
Andrew Geissler82c905d2020-04-13 13:39:40 -050010
11EXTRA_OECONF = " \
12 --disable-procacpi \
13 --disable-xnvctrl \
14"
15
Patrick Williams213cb262021-08-07 19:21:33 -050016do_configure:prepend() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050017 sed -i 's:LIBSENSORS_CFLAGS=.*:LIBSENSORS_CFLAGS=-I${STAGING_INCDIR}:g' ${S}/configure.ac
18}
19
20PACKAGECONFIG[libsensors] = "--enable-libsensors,--disable-libsensors, lmsensors"
21PACKAGECONFIG[hddtemp] = "--enable-hddtemp,--disable-hddtemp, hddtemp"
22PACKAGECONFIG[netcat] = "--enable-netcat,--disable-netcat, netcat"
23PACKAGECONFIG[libnotify] = "--enable-notification,--disable-notification, libnotify"
24
25FILES_SOLIBSDEV = "${libdir}/xfce4/modules/lib*${SOLIBSDEV}"