blob: b80ef7973221136f34f2a7a78464c29c77a43044 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "TPM2 Access Broker & Resource Manager"
2DESCRIPTION = "This is a system daemon implementing the TPM2 access \
3broker (TAB) & Resource Manager (RM) spec from the TCG. The daemon (tpm2-abrmd) \
4is implemented using Glib and the GObject system. In this documentation and \
5in the code we use `tpm2-abrmd` and `tabrmd` interchangeably. \
6"
7SECTION = "security/tpm"
8
9LICENSE = "BSD-2-Clause"
10LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=500b2e742befc3da00684d8a1d5fd9da"
11
12DEPENDS = "autoconf-archive dbus glib-2.0 tpm2-tss glib-2.0-native \
13 libtss2 libtss2-mu libtss2-tcti-device libtss2-tcti-mssim"
14
Brad Bishop19323692019-04-05 15:28:33 -040015SRC_URI = "\
16 git://github.com/tpm2-software/tpm2-abrmd.git \
17 file://tpm2-abrmd-init.sh \
18 file://tpm2-abrmd.default \
19"
20
Andrew Geissler9d3cc052021-03-31 13:36:22 -050021SRCREV = "4f332013a02c422e186c4aaf127ab6a40b996028"
Brad Bishop19323692019-04-05 15:28:33 -040022
23S = "${WORKDIR}/git"
24
25inherit autotools pkgconfig systemd update-rc.d useradd
26
27SYSTEMD_PACKAGES += "${PN}"
Patrick Williams213cb262021-08-07 19:21:33 -050028SYSTEMD_SERVICE:${PN} = "tpm2-abrmd.service"
29SYSTEMD_AUTO_ENABLE:${PN} = "disable"
Brad Bishop19323692019-04-05 15:28:33 -040030
31INITSCRIPT_NAME = "${PN}"
32INITSCRIPT_PARAMS = "start 99 2 3 4 5 . stop 19 0 1 6 ."
33
34USERADD_PACKAGES = "${PN}"
Patrick Williams213cb262021-08-07 19:21:33 -050035GROUPADD_PARAM:${PN} = "tss"
36USERADD_PARAM:${PN} = "--system -M -d /var/lib/tpm -s /bin/false -g tss tss"
Brad Bishop19323692019-04-05 15:28:33 -040037
38PACKAGECONFIG ?="${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd', '', d)}"
39PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_system_unitdir}, --with-systemdsystemunitdir=no"
40
Patrick Williams213cb262021-08-07 19:21:33 -050041do_install:append() {
Brad Bishop19323692019-04-05 15:28:33 -040042 install -d "${D}${sysconfdir}/init.d"
43 install -m 0755 "${WORKDIR}/tpm2-abrmd-init.sh" "${D}${sysconfdir}/init.d/tpm2-abrmd"
44
45 install -d "${D}${sysconfdir}/default"
46 install -m 0644 "${WORKDIR}/tpm2-abrmd.default" "${D}${sysconfdir}/default/tpm2-abrmd"
47}
48
Patrick Williams213cb262021-08-07 19:21:33 -050049FILES:${PN} += "${libdir}/systemd/system-preset \
Brad Bishop19323692019-04-05 15:28:33 -040050 ${datadir}/dbus-1"
51
Patrick Williams213cb262021-08-07 19:21:33 -050052RDEPENDS:${PN} += "tpm2-tss"
Brad Bishop19323692019-04-05 15:28:33 -040053
54BBCLASSEXTEND = "native"