blob: 26f549b6c0e46d120ee1e2cb77a56fc631e1b55b [file] [log] [blame]
Richard Marian Thomaiyar14fddef2018-07-13 23:55:56 +05301SUMMARY = "low-level tool handling Linux filesystem encryption"
2DESCIPTION = "fscryptctl is a low-level tool written in C that handles raw keys and manages \
3policies for Linux filesystem encryption (https://lwn.net/Articles/639427). \
4For a tool that presents a higher level interface and manages metadata, key \
5generation, key wrapping, PAM integration, and passphrase hashing, see \
6fscrypt (https://github.com/google/fscrypt)."
7HOMEPAGE = "https://github.com/google/fscryptctl"
8SECTION = "base"
9LICENSE = "Apache-2.0"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
11
Andrew Geissler8b139282021-03-05 15:22:30 -060012SRCREV = "56b898c896240328adef7407090215abbe9ee03d"
Richard Marian Thomaiyar14fddef2018-07-13 23:55:56 +053013SRC_URI = "git://github.com/google/fscryptctl.git"
14
15S = "${WORKDIR}/git"
16
17do_install() {
Andrew Geissler9d3cc052021-03-31 13:36:22 -050018 oe_runmake DESTDIR=${D} PREFIX=/usr install
Richard Marian Thomaiyar14fddef2018-07-13 23:55:56 +053019}
20
Patrick Williams213cb262021-08-07 19:21:33 -050021RRECOMMENDS:${PN} += "\
Richard Marian Thomaiyar14fddef2018-07-13 23:55:56 +053022 keyutils \
23 kernel-module-cbc \
24 kernel-module-cts \
25 kernel-module-ecb \
26 kernel-module-xts \
27"