blob: 7149bc06c0b3342b62ee1bf4eb840d406cbcbef5 [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001# Helper class to pull in the right gtk-doc dependencies and configure
2# gtk-doc to enable or disable documentation building (which requries the
3# use of usermode qemu).
4
5# This variable is set to True if api-documentation is in
6# DISTRO_FEATURES and qemu-usermode is in MACHINE_FEATURES, and False otherwise.
Patrick Williamsc124f4f2015-09-15 14:41:29 -05007#
Patrick Williamsc0f7c042017-02-23 20:41:17 -06008# It should be used in recipes to determine whether gtk-doc based documentation should be built,
9# so that qemu use can be avoided when necessary.
Patrick Williams213cb262021-08-07 19:21:33 -050010GTKDOC_ENABLED:class-native = "False"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060011GTKDOC_ENABLED ?= "${@bb.utils.contains('DISTRO_FEATURES', 'api-documentation', \
12 bb.utils.contains('MACHINE_FEATURES', 'qemu-usermode', 'True', 'False', d), 'False', d)}"
13
Brad Bishopc342db32019-05-15 21:57:59 -040014# meson: default option name to enable/disable gtk-doc. This matches most
15# project's configuration. In doubts - check meson_options.txt in project's
16# source path.
17GTKDOC_MESON_OPTION ?= 'docs'
18GTKDOC_MESON_ENABLE_FLAG ?= 'true'
19GTKDOC_MESON_DISABLE_FLAG ?= 'false'
20
21# Auto enable/disable based on GTKDOC_ENABLED
Patrick Williams213cb262021-08-07 19:21:33 -050022EXTRA_OECONF:prepend:class-target = "${@bb.utils.contains('GTKDOC_ENABLED', 'True', '--enable-gtk-doc --enable-gtk-doc-html --disable-gtk-doc-pdf', \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060023 '--disable-gtk-doc', d)} "
Patrick Williams213cb262021-08-07 19:21:33 -050024EXTRA_OEMESON:prepend:class-target = "-D${GTKDOC_MESON_OPTION}=${@bb.utils.contains('GTKDOC_ENABLED', 'True', '${GTKDOC_MESON_ENABLE_FLAG}', '${GTKDOC_MESON_DISABLE_FLAG}', d)} "
Patrick Williamsc0f7c042017-02-23 20:41:17 -060025
26# When building native recipes, disable gtkdoc, as it is not necessary,
27# pulls in additional dependencies, and makes build times longer
Patrick Williams213cb262021-08-07 19:21:33 -050028EXTRA_OECONF:prepend:class-native = "--disable-gtk-doc "
29EXTRA_OECONF:prepend:class-nativesdk = "--disable-gtk-doc "
30EXTRA_OEMESON:prepend:class-native = "-D${GTKDOC_MESON_OPTION}=${GTKDOC_MESON_DISABLE_FLAG} "
31EXTRA_OEMESON:prepend:class-nativesdk = "-D${GTKDOC_MESON_OPTION}=${GTKDOC_MESON_DISABLE_FLAG} "
Patrick Williamsc0f7c042017-02-23 20:41:17 -060032
Patrick Williamsc0f7c042017-02-23 20:41:17 -060033# Even though gtkdoc is disabled on -native, gtk-doc package is still
34# needed for m4 macros.
Patrick Williams213cb262021-08-07 19:21:33 -050035DEPENDS:append = " gtk-doc-native"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050036
37# The documentation directory, where the infrastructure will be copied.
38# gtkdocize has a default of "." so to handle out-of-tree builds set this to $S.
39GTKDOC_DOCDIR ?= "${S}"
40
Patrick Williamsc0f7c042017-02-23 20:41:17 -060041export STAGING_DIR_HOST
42
Brad Bishop316dfdd2018-06-25 12:45:53 -040043inherit python3native pkgconfig qemu
Patrick Williams213cb262021-08-07 19:21:33 -050044DEPENDS:append = "${@' qemu-native' if d.getVar('GTKDOC_ENABLED') == 'True' else ''}"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060045
Patrick Williams213cb262021-08-07 19:21:33 -050046do_configure:prepend () {
Brad Bishop316dfdd2018-06-25 12:45:53 -040047 # Need to use ||true as this is only needed if configure.ac both exists
48 # and uses GTK_DOC_CHECK.
49 gtkdocize --srcdir ${S} --docdir ${GTKDOC_DOCDIR} || true
50}
51
Patrick Williams213cb262021-08-07 19:21:33 -050052do_compile:prepend:class-target () {
Brad Bishop316dfdd2018-06-25 12:45:53 -040053 if [ ${GTKDOC_ENABLED} = True ]; then
Patrick Williamsc0f7c042017-02-23 20:41:17 -060054 # Write out a qemu wrapper that will be given to gtkdoc-scangobj so that it
55 # can run target helper binaries through that.
Brad Bishop19323692019-04-05 15:28:33 -040056 qemu_binary="${@qemu_wrapper_cmdline(d, '$STAGING_DIR_HOST', ['\\$GIR_EXTRA_LIBS_PATH','$STAGING_DIR_HOST/${libdir}','$STAGING_DIR_HOST/${base_libdir}'])}"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060057 cat > ${B}/gtkdoc-qemuwrapper << EOF
58#!/bin/sh
59# Use a modules directory which doesn't exist so we don't load random things
60# which may then get deleted (or their dependencies) and potentially segfault
61export GIO_MODULE_DIR=${STAGING_LIBDIR}/gio/modules-dummy
62
Brad Bishopd7bf8c12018-02-25 22:55:05 -050063GIR_EXTRA_LIBS_PATH=\`find ${B} -name *.so -printf "%h\n"|sort|uniq| tr '\n' ':'\`\$GIR_EXTRA_LIBS_PATH
Patrick Williamsc0f7c042017-02-23 20:41:17 -060064GIR_EXTRA_LIBS_PATH=\`find ${B} -name .libs| tr '\n' ':'\`\$GIR_EXTRA_LIBS_PATH
65
Brad Bishop19323692019-04-05 15:28:33 -040066# meson sets this wrongly (only to libs in build-dir), qemu-wrapper_cmdline() and GIR_EXTRA_LIBS_PATH take care of it properly
67unset LD_LIBRARY_PATH
68
Brad Bishop6e60e8b2018-02-01 10:27:11 -050069if [ -d ".libs" ]; then
Patrick Williamsc0f7c042017-02-23 20:41:17 -060070 $qemu_binary ".libs/\$@"
71else
72 $qemu_binary "\$@"
73fi
74
75if [ \$? -ne 0 ]; then
76 echo "If the above error message is about missing .so libraries, then setting up GIR_EXTRA_LIBS_PATH in the recipe should help."
77 echo "(typically like this: GIR_EXTRA_LIBS_PATH=\"$""{B}/something/.libs\" )"
78 exit 1
79fi
80EOF
81 chmod +x ${B}/gtkdoc-qemuwrapper
Brad Bishop316dfdd2018-06-25 12:45:53 -040082 fi
Patrick Williamsc0f7c042017-02-23 20:41:17 -060083}