blob: bf529e9aa4bf5970b978c83fc523e0fe08c8ad5a [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001# Help runqemu boot target board, "QB" means Qemu Boot, the following
2# vars can be set in conf files, such as <bsp.conf> to make it can be
3# boot by runqemu:
4#
5# QB_SYSTEM_NAME: qemu name, e.g., "qemu-system-i386"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05006#
Andrew Geisslerd25ed322020-06-27 00:28:28 -05007# QB_OPT_APPEND: options to append to qemu, e.g., "-device usb-mouse"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05008#
Patrick Williamsc0f7c042017-02-23 20:41:17 -06009# QB_DEFAULT_KERNEL: default kernel to boot, e.g., "bzImage"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050010#
Patrick Williamsc0f7c042017-02-23 20:41:17 -060011# QB_DEFAULT_FSTYPE: default FSTYPE to boot, e.g., "ext4"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050012#
Patrick Williamsc0f7c042017-02-23 20:41:17 -060013# QB_MEM: memory, e.g., "-m 512"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050014#
Patrick Williamsc0f7c042017-02-23 20:41:17 -060015# QB_MACHINE: qemu machine, e.g., "-machine virt"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050016#
Patrick Williamsc0f7c042017-02-23 20:41:17 -060017# QB_CPU: qemu cpu, e.g., "-cpu qemu32"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050018#
Patrick Williamsc0f7c042017-02-23 20:41:17 -060019# QB_CPU_KVM: the similar to QB_CPU, but used when kvm, e.g., '-cpu kvm64',
20# set it when support kvm.
Brad Bishop6e60e8b2018-02-01 10:27:11 -050021#
William A. Kennington IIIac69b482021-06-02 12:28:27 -070022# QB_SMP: amount of CPU cores inside qemu guest, each mapped to a thread on the host,
23# e.g. "-smp 8".
24#
Patrick Williamsc0f7c042017-02-23 20:41:17 -060025# QB_KERNEL_CMDLINE_APPEND: options to append to kernel's -append
26# option, e.g., "console=ttyS0 console=tty"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050027#
Patrick Williamsc0f7c042017-02-23 20:41:17 -060028# QB_DTB: qemu dtb name
Brad Bishop6e60e8b2018-02-01 10:27:11 -050029#
Patrick Williamsc0f7c042017-02-23 20:41:17 -060030# QB_AUDIO_DRV: qemu audio driver, e.g., "alsa", set it when support audio
Brad Bishop6e60e8b2018-02-01 10:27:11 -050031#
Patrick Williamsc0f7c042017-02-23 20:41:17 -060032# QB_AUDIO_OPT: qemu audio option, e.g., "-soundhw ac97,es1370", used
33# when QB_AUDIO_DRV is set.
Brad Bishop6e60e8b2018-02-01 10:27:11 -050034#
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050035# QB_RNG: Pass-through for host random number generator, it can speedup boot
36# in system mode, where system is experiencing entropy starvation
37#
Patrick Williamsc0f7c042017-02-23 20:41:17 -060038# QB_KERNEL_ROOT: kernel's root, e.g., /dev/vda
Brad Bishop6e60e8b2018-02-01 10:27:11 -050039#
40# QB_NETWORK_DEVICE: network device, e.g., "-device virtio-net-pci,netdev=net0,mac=@MAC@",
41# it needs work with QB_TAP_OPT and QB_SLIRP_OPT.
42# Note, runqemu will replace @MAC@ with a predefined mac, you can set
43# a custom one, but that may cause conflicts when multiple qemus are
44# running on the same host.
Andrew Geissler82c905d2020-04-13 13:39:40 -050045# Note: If more than one interface of type -device virtio-net-device gets added,
Patrick Williams213cb262021-08-07 19:21:33 -050046# QB_NETWORK_DEVICE:prepend might be used, since Qemu enumerates the eth*
Andrew Geissler82c905d2020-04-13 13:39:40 -050047# devices in reverse order to -device arguments.
Brad Bishop6e60e8b2018-02-01 10:27:11 -050048#
Andrew Geissler6ce62a22020-11-30 19:58:47 -060049# QB_TAP_OPT: network option for 'tap' mode, e.g.,
Brad Bishop6e60e8b2018-02-01 10:27:11 -050050# "-netdev tap,id=net0,ifname=@TAP@,script=no,downscript=no"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060051# Note, runqemu will replace "@TAP@" with the one which is used, such as tap0, tap1 ...
Brad Bishop6e60e8b2018-02-01 10:27:11 -050052#
53# QB_SLIRP_OPT: network option for SLIRP mode, e.g., -netdev user,id=net0"
54#
Andrew Geissler82c905d2020-04-13 13:39:40 -050055# QB_CMDLINE_IP_SLIRP: If QB_NETWORK_DEVICE adds more than one network interface to qemu, usually the
56# ip= kernel comand line argument needs to be changed accordingly. Details are documented
57# in the kernel docuemntation https://www.kernel.org/doc/Documentation/filesystems/nfs/nfsroot.txt
58# Example to configure only the first interface: "ip=eth0:dhcp"
59# QB_CMDLINE_IP_TAP: This parameter is similar to the QB_CMDLINE_IP_SLIRP parameter. Since the tap interface requires
60# static IP configuration @CLIENT@ and @GATEWAY@ place holders are replaced by the IP and the gateway
61# address of the qemu guest by runqemu.
62# Example: "ip=192.168.7.@CLIENT@::192.168.7.@GATEWAY@:255.255.255.0::eth0"
63#
Patrick Williamsc0f7c042017-02-23 20:41:17 -060064# QB_ROOTFS_OPT: used as rootfs, e.g.,
65# "-drive id=disk0,file=@ROOTFS@,if=none,format=raw -device virtio-blk-device,drive=disk0"
66# Note, runqemu will replace "@ROOTFS@" with the one which is used, such as core-image-minimal-qemuarm64.ext4.
Brad Bishop6e60e8b2018-02-01 10:27:11 -050067#
Patrick Williamsc0f7c042017-02-23 20:41:17 -060068# QB_SERIAL_OPT: serial port, e.g., "-serial mon:stdio"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050069#
Patrick Williamsc0f7c042017-02-23 20:41:17 -060070# QB_TCPSERIAL_OPT: tcp serial port option, e.g.,
71# " -device virtio-serial-device -chardev socket,id=virtcon,port=@PORT@,host=127.0.0.1 -device virtconsole,chardev=virtcon"
72# Note, runqemu will replace "@PORT@" with the port number which is used.
73#
Andrew Geissler82c905d2020-04-13 13:39:40 -050074# QB_ROOTFS_EXTRA_OPT: extra options to be appended to the rootfs device in case there is none specified by QB_ROOTFS_OPT.
75# Can be used to automatically determine the image from the other variables
76# but define things link 'bootindex' when booting from EFI or 'readonly' when using squashfs
77# without the need to specify a dedicated qemu configuration
Andrew Geissler95ac1b82021-03-31 14:34:31 -050078#
79# QB_GRAPHICS: QEMU video card type (e.g. "-vga std")
80#
Patrick Williamsc0f7c042017-02-23 20:41:17 -060081# Usage:
82# IMAGE_CLASSES += "qemuboot"
83# See "runqemu help" for more info
84
85QB_MEM ?= "-m 256"
William A. Kennington IIIac69b482021-06-02 12:28:27 -070086QB_SMP ?= ""
Patrick Williamsc0f7c042017-02-23 20:41:17 -060087QB_SERIAL_OPT ?= "-serial mon:stdio -serial null"
88QB_DEFAULT_KERNEL ?= "${KERNEL_IMAGETYPE}"
89QB_DEFAULT_FSTYPE ?= "ext4"
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050090QB_RNG ?= "-object rng-random,filename=/dev/urandom,id=rng0 -device virtio-rng-pci,rng=rng0"
Andrew Geisslerd25ed322020-06-27 00:28:28 -050091QB_OPT_APPEND ?= ""
Brad Bishop6e60e8b2018-02-01 10:27:11 -050092QB_NETWORK_DEVICE ?= "-device virtio-net-pci,netdev=net0,mac=@MAC@"
Andrew Geissler82c905d2020-04-13 13:39:40 -050093QB_CMDLINE_IP_SLIRP ?= "ip=dhcp"
94QB_CMDLINE_IP_TAP ?= "ip=192.168.7.@CLIENT@::192.168.7.@GATEWAY@:255.255.255.0"
95QB_ROOTFS_EXTRA_OPT ?= ""
Andrew Geissler95ac1b82021-03-31 14:34:31 -050096QB_GRAPHICS ?= ""
Brad Bishop6e60e8b2018-02-01 10:27:11 -050097
98# This should be kept align with ROOT_VM
99QB_DRIVE_TYPE ?= "/dev/sd"
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600100
Andrew Geisslerc9f78652020-09-18 14:11:35 -0500101inherit image-artifact-names
102
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600103# Create qemuboot.conf
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500104addtask do_write_qemuboot_conf after do_rootfs before do_image
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600105
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500106def qemuboot_vars(d):
107 build_vars = ['MACHINE', 'TUNE_ARCH', 'DEPLOY_DIR_IMAGE',
108 'KERNEL_IMAGETYPE', 'IMAGE_NAME', 'IMAGE_LINK_NAME',
109 'STAGING_DIR_NATIVE', 'STAGING_BINDIR_NATIVE',
Andrew Geissler95ac1b82021-03-31 14:34:31 -0500110 'STAGING_DIR_HOST', 'SERIAL_CONSOLES']
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500111 return build_vars + [k for k in d.keys() if k.startswith('QB_')]
112
113do_write_qemuboot_conf[vardeps] += "${@' '.join(qemuboot_vars(d))}"
114do_write_qemuboot_conf[vardepsexclude] += "TOPDIR"
115python do_write_qemuboot_conf() {
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600116 import configparser
117
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500118 qemuboot = "%s/%s.qemuboot.conf" % (d.getVar('IMGDEPLOYDIR'), d.getVar('IMAGE_NAME'))
119 qemuboot_link = "%s/%s.qemuboot.conf" % (d.getVar('IMGDEPLOYDIR'), d.getVar('IMAGE_LINK_NAME'))
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500120 finalpath = d.getVar("DEPLOY_DIR_IMAGE")
121 topdir = d.getVar('TOPDIR')
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600122 cf = configparser.ConfigParser()
123 cf.add_section('config_bsp')
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500124 for k in sorted(qemuboot_vars(d)):
Patrick Williams213cb262021-08-07 19:21:33 -0500125 if ":" in k:
126 continue
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500127 # qemu-helper-native sysroot is not removed by rm_work and
128 # contains all tools required by runqemu
129 if k == 'STAGING_BINDIR_NATIVE':
130 val = os.path.join(d.getVar('BASE_WORKDIR'), d.getVar('BUILD_SYS'),
131 'qemu-helper-native/1.0-r1/recipe-sysroot-native/usr/bin/')
132 else:
133 val = d.getVar(k)
134 # we only want to write out relative paths so that we can relocate images
135 # and still run them
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500136 if val.startswith(topdir):
137 val = os.path.relpath(val, finalpath)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500138 cf.set('config_bsp', k, '%s' % val)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600139
140 # QB_DEFAULT_KERNEL's value of KERNEL_IMAGETYPE is the name of a symlink
141 # to the kernel file, which hinders relocatability of the qb conf.
142 # Read the link and replace it with the full filename of the target.
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500143 kernel_link = os.path.join(d.getVar('DEPLOY_DIR_IMAGE'), d.getVar('QB_DEFAULT_KERNEL'))
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600144 kernel = os.path.realpath(kernel_link)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500145 # we only want to write out relative paths so that we can relocate images
146 # and still run them
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500147 kernel = os.path.relpath(kernel, finalpath)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600148 cf.set('config_bsp', 'QB_DEFAULT_KERNEL', kernel)
149
150 bb.utils.mkdirhier(os.path.dirname(qemuboot))
151 with open(qemuboot, 'w') as f:
152 cf.write(f)
153
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500154 if qemuboot_link != qemuboot:
155 if os.path.lexists(qemuboot_link):
156 os.remove(qemuboot_link)
157 os.symlink(os.path.basename(qemuboot), qemuboot_link)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600158}