blob: 57ec0acbc531fe127c9ac283b9b8298d90319b01 [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001# Copyright (C) 2016 Intel Corporation
2#
3# Released under the MIT license (see COPYING.MIT)
4
5# systemd-boot.bbclass - The "systemd-boot" is essentially the gummiboot merged into systemd.
6# The original standalone gummiboot project is dead without any more
Brad Bishop6e60e8b2018-02-01 10:27:11 -05007# maintenance.
Patrick Williamsc0f7c042017-02-23 20:41:17 -06008#
9# Set EFI_PROVIDER = "systemd-boot" to use systemd-boot on your live images instead of grub-efi
Brad Bishopd7bf8c12018-02-25 22:55:05 -050010# (images built by image-live.bbclass)
Patrick Williamsc0f7c042017-02-23 20:41:17 -060011
12do_bootimg[depends] += "${MLPREFIX}systemd-boot:do_deploy"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060013
Brad Bishopa34c0302019-09-23 22:34:48 -040014require conf/image-uefi.conf
Patrick Williamsc0f7c042017-02-23 20:41:17 -060015# Need UUID utility code.
16inherit fs-uuid
17
18efi_populate() {
Brad Bishopa34c0302019-09-23 22:34:48 -040019 efi_populate_common "$1" systemd
Patrick Williamsc0f7c042017-02-23 20:41:17 -060020
Patrick Williamsc0f7c042017-02-23 20:41:17 -060021 # systemd-boot requires these paths for configuration files
22 # they are not customizable so no point in new vars
23 install -d ${DEST}/loader
24 install -d ${DEST}/loader/entries
Patrick Williamsc0f7c042017-02-23 20:41:17 -060025 install -m 0644 ${SYSTEMD_BOOT_CFG} ${DEST}/loader/loader.conf
26 for i in ${SYSTEMD_BOOT_ENTRIES}; do
27 install -m 0644 ${i} ${DEST}/loader/entries
28 done
29}
30
Patrick Williams213cb262021-08-07 19:21:33 -050031efi_iso_populate:append() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050032 cp -r $iso_dir/loader ${EFIIMGDIR}
Patrick Williamsc0f7c042017-02-23 20:41:17 -060033}
34
Brad Bishop316dfdd2018-06-25 12:45:53 -040035inherit systemd-boot-cfg