blob: b011276f47f1fa29f83d4328d7f34df4c8f19290 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "User support binary for the uvesafb kernel module"
Andrew Geissler6ce62a22020-11-30 19:58:47 -06002HOMEPAGE = "https://tracker.debian.org/pkg/v86d"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06003DESCRIPTION = "v86d provides a backend for kernel drivers that need to execute x86 BIOS code. The code is executed in a controlled environment and the results are passed back to the kernel via the netlink interface."
Patrick Williamsc124f4f2015-09-15 14:41:29 -05004
5# the copyright info is at the bottom of README, expect break
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://README;md5=94ac1971e4f2309dc322d598e7b1f7dd"
8
9DEPENDS = "virtual/kernel"
Patrick Williams213cb262021-08-07 19:21:33 -050010RRECOMMENDS:${PN} = "kernel-module-uvesafb"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050011PR = "r2"
12
Brad Bishop316dfdd2018-06-25 12:45:53 -040013SRC_URI = "http://snapshot.debian.org/archive/debian/20110427T035506Z/pool/main/v/${BPN}/${BPN}_${PV}.orig.tar.gz \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050014 file://Update-x86emu-from-X.org.patch \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060015 file://ar-from-env.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080016 file://Support-for-cross-compilation.patch \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060017"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050018
Brad Bishop6e60e8b2018-02-01 10:27:11 -050019SRC_URI[md5sum] = "889686ec8424468fe0d205742e77a4c2"
20SRC_URI[sha256sum] = "93575c82e4307d8c4c370ec6b767f5cf87e527b2378146d652a6d8e25d5bdbc5"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050021
22PACKAGE_ARCH = "${MACHINE_ARCH}"
23COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
24
Patrick Williamsc124f4f2015-09-15 14:41:29 -050025do_configure () {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080026 TARGET_ARCH="${TARGET_ARCH}" ./configure --with-x86emu
Patrick Williamsc124f4f2015-09-15 14:41:29 -050027}
28
29do_compile () {
30 KDIR="${STAGING_DIR_HOST}/usr" make
31}
32
33do_install () {
34 install -d ${D}${base_sbindir}
35 install v86d ${D}${base_sbindir}/
Patrick Williamsc124f4f2015-09-15 14:41:29 -050036}