blob: d55cf6a37712866654e9a2167b7e44cb0604b37d [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001SUMMARY = "Linux NFC daemon"
2DESCRIPTION = "A daemon for the Linux Near Field Communication stack"
3HOMEPAGE = "http://01.org/linux-nfc"
4LICENSE = "GPLv2"
5
6DEPENDS = "dbus glib-2.0 libnl"
7
8SRC_URI = "${KERNELORG_MIRROR}/linux/network/nfc/${BP}.tar.xz \
9 file://neard.in \
10 file://Makefile.am-fix-parallel-issue.patch \
11 file://Makefile.am-do-not-ship-version.h.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050012 file://0001-Add-header-dependency-to-nciattach.o.patch \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060013 "
14SRC_URI[md5sum] = "5c691fb7872856dc0d909c298bc8cb41"
15SRC_URI[sha256sum] = "eae3b11c541a988ec11ca94b7deab01080cd5b58cfef3ced6ceac9b6e6e65b36"
16
17LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
18 file://src/near.h;beginline=1;endline=20;md5=358e4deefef251a4761e1ffacc965d13 \
19 "
20
Brad Bishop96ff1982019-08-19 13:50:42 -040021inherit autotools pkgconfig systemd update-rc.d
Patrick Williamsc0f7c042017-02-23 20:41:17 -060022
Brad Bishop6e60e8b2018-02-01 10:27:11 -050023PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060024
25PACKAGECONFIG[systemd] = "--enable-systemd --with-systemdsystemunitdir=${systemd_unitdir}/system/ --with-systemduserunitdir=${systemd_unitdir}/user/,--disable-systemd"
26
27EXTRA_OECONF += "--enable-tools"
28
29# This would copy neard start-stop shell and test scripts
Patrick Williams213cb262021-08-07 19:21:33 -050030do_install:append() {
Patrick Williamsc0f7c042017-02-23 20:41:17 -060031 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
32 install -d ${D}${sysconfdir}/init.d/
33 sed "s:@installpath@:${libexecdir}/nfc:" ${WORKDIR}/neard.in \
34 > ${D}${sysconfdir}/init.d/neard
35 chmod 0755 ${D}${sysconfdir}/init.d/neard
36 fi
37}
38
Patrick Williams213cb262021-08-07 19:21:33 -050039RDEPENDS:${PN} = "dbus"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060040
41# Bluez & Wifi are not mandatory except for handover
Patrick Williams213cb262021-08-07 19:21:33 -050042RRECOMMENDS:${PN} = "\
Brad Bishop96ff1982019-08-19 13:50:42 -040043 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez5', '', d)} \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060044 ${@bb.utils.contains('DISTRO_FEATURES', 'wifi','wpa-supplicant', '', d)} \
45 "
46
47INITSCRIPT_NAME = "neard"
48INITSCRIPT_PARAMS = "defaults 64"
49
Patrick Williams213cb262021-08-07 19:21:33 -050050SYSTEMD_SERVICE:${PN} = "neard.service"