blob: f82572ed5209b46f96d009e5f2f71f2964e0fd3e [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "The basic file, shell and text manipulation utilities"
2DESCRIPTION = "The GNU Core Utilities provide the basic file, shell and text \
3manipulation utilities. These are the core utilities which are expected to exist on \
4every system."
5HOMEPAGE = "http://www.gnu.org/software/coreutils/"
6BUGTRACKER = "http://debbugs.gnu.org/coreutils"
7LICENSE = "GPLv3+"
Andrew Geissler4b740dc2020-05-05 08:54:39 -05008LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464 \
9 file://src/ls.c;beginline=1;endline=15;md5=b7d80abf5b279320fb0e4b1007ed108b \
10 "
Brad Bishopc342db32019-05-15 21:57:59 -040011DEPENDS = "gmp libcap"
Patrick Williams213cb262021-08-07 19:21:33 -050012DEPENDS:class-native = ""
Brad Bishopc342db32019-05-15 21:57:59 -040013
14inherit autotools gettext texinfo
15
16SRC_URI = "${GNU_MIRROR}/coreutils/${BP}.tar.xz \
17 file://remove-usr-local-lib-from-m4.patch \
18 file://fix-selinux-flask.patch \
19 file://0001-uname-report-processor-and-hardware-correctly.patch \
20 file://disable-ls-output-quoting.patch \
21 file://0001-local.mk-fix-cross-compiling-problem.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050022 file://run-ptest \
Andrew Geissler4b740dc2020-05-05 08:54:39 -050023 file://0001-ls-restore-8.31-behavior-on-removed-directories.patch \
Andrew Geissler09036742021-06-25 14:25:14 -050024 file://0001-fts-remove-NOSTAT_LEAF_OPTIMIZATION.patch \
Andrew Geissler4b740dc2020-05-05 08:54:39 -050025 "
Brad Bishopc342db32019-05-15 21:57:59 -040026
Andrew Geissler4b740dc2020-05-05 08:54:39 -050027SRC_URI[md5sum] = "022042695b7d5bcf1a93559a9735e668"
28SRC_URI[sha256sum] = "4458d8de7849df44ccab15e16b1548b285224dbba5f08fac070c1c0e0bcc4cfa"
Brad Bishopc342db32019-05-15 21:57:59 -040029
William A. Kennington IIIac69b482021-06-02 12:28:27 -070030# http://git.savannah.gnu.org/cgit/coreutils.git/commit/?id=v8.27-101-gf5d7c0842
31# runcon is not really a sandbox command, use `runcon ... setsid ...` to avoid this particular issue.
32CVE_CHECK_WHITELIST += "CVE-2016-2781"
33
Patrick Williams213cb262021-08-07 19:21:33 -050034EXTRA_OECONF:class-native = "--without-gmp"
35EXTRA_OECONF:class-target = "--enable-install-program=arch,hostname --libexecdir=${libdir}"
36EXTRA_OECONF:class-nativesdk = "--enable-install-program=arch,hostname"
Brad Bishopc342db32019-05-15 21:57:59 -040037
38# acl and xattr are not default features
39#
Patrick Williams213cb262021-08-07 19:21:33 -050040PACKAGECONFIG:class-target ??= "\
Brad Bishopc342db32019-05-15 21:57:59 -040041 ${@bb.utils.filter('DISTRO_FEATURES', 'acl xattr', d)} \
42"
43
44# The lib/oe/path.py requires xattr
Patrick Williams213cb262021-08-07 19:21:33 -050045PACKAGECONFIG:class-native ??= "xattr"
Brad Bishopc342db32019-05-15 21:57:59 -040046
Andrew Geisslerd1e89492021-02-12 15:35:20 -060047# oe-core builds need xattr support
Patrick Williams213cb262021-08-07 19:21:33 -050048PACKAGECONFIG:class-nativesdk ??= "xattr"
Andrew Geisslerd1e89492021-02-12 15:35:20 -060049
Brad Bishopc342db32019-05-15 21:57:59 -040050# with, without, depends, rdepends
51#
52PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl,"
53PACKAGECONFIG[xattr] = "--enable-xattr,--disable-xattr,attr,"
54PACKAGECONFIG[single-binary] = "--enable-single-binary,--disable-single-binary,,"
55
56# [ df mktemp nice printenv base64 gets a special treatment and is not included in this
57bindir_progs = "arch basename chcon cksum comm csplit cut dir dircolors dirname du \
58 env expand expr factor fmt fold groups head hostid id install \
59 join link logname md5sum mkfifo nl nohup nproc od paste pathchk \
60 pinky pr printf ptx readlink realpath runcon seq sha1sum sha224sum sha256sum \
Brad Bishop64c979e2019-11-04 13:55:29 -050061 sha384sum sha512sum shred shuf sort split sum tac tail tee test timeout \
Brad Bishopc342db32019-05-15 21:57:59 -040062 tr truncate tsort tty unexpand uniq unlink uptime users vdir wc who whoami yes"
63
64# hostname gets a special treatment and is not included in this
65base_bindir_progs = "cat chgrp chmod chown cp date dd echo false hostname kill ln ls mkdir \
66 mknod mv pwd rm rmdir sleep stty sync touch true uname stat"
67
68sbindir_progs= "chroot"
69
Andrew Geissler475cb722020-07-10 16:00:51 -050070# Split stdbuf into its own package, so one can include
71# coreutils-stdbuf without getting the rest of coreutils, but make
72# coreutils itself pull in stdbuf, so IMAGE_INSTALL += "coreutils"
73# always provides all coreutils
Patrick Williams213cb262021-08-07 19:21:33 -050074PACKAGE_BEFORE_PN:class-target += "${@bb.utils.contains('PACKAGECONFIG', 'single-binary', '', 'coreutils-stdbuf', d)}"
75FILES:coreutils-stdbuf = "${bindir}/stdbuf ${libdir}/coreutils/libstdbuf.so"
76RDEPENDS:coreutils:class-target += "${@bb.utils.contains('PACKAGECONFIG', 'single-binary', '', 'coreutils-stdbuf', d)}"
Andrew Geissler475cb722020-07-10 16:00:51 -050077
78# However, when the single-binary PACKAGECONFIG is used, stdbuf
79# functionality is built into the single coreutils binary, so there's
80# no point splitting /usr/bin/stdbuf to its own package. Instead, add
81# an RPROVIDE so that rdepending on coreutils-stdbuf will work
82# regardless of whether single-binary is in effect.
Patrick Williams213cb262021-08-07 19:21:33 -050083RPROVIDES:coreutils += "${@bb.utils.contains('PACKAGECONFIG', 'single-binary', 'coreutils-stdbuf', '', d)}"
Brad Bishop64c979e2019-11-04 13:55:29 -050084
Brad Bishopc342db32019-05-15 21:57:59 -040085# Let aclocal use the relative path for the m4 file rather than the
86# absolute since coreutils has a lot of m4 files, otherwise there might
87# be an "Argument list too long" error when it is built in a long/deep
88# directory.
89acpaths = "-I ./m4"
90
91# Deal with a separate builddir failure if src doesn't exist when creating version.c/version.h
Patrick Williams213cb262021-08-07 19:21:33 -050092do_compile:prepend () {
Brad Bishopc342db32019-05-15 21:57:59 -040093 mkdir -p ${B}/src
94}
95
Patrick Williams213cb262021-08-07 19:21:33 -050096do_install:class-native() {
Brad Bishopc342db32019-05-15 21:57:59 -040097 autotools_do_install
98 # remove groups to fix conflict with shadow-native
99 rm -f ${D}${STAGING_BINDIR_NATIVE}/groups
100 # The return is a must since native doesn't need the
Patrick Williams213cb262021-08-07 19:21:33 -0500101 # do_install:append() in the below.
Brad Bishopc342db32019-05-15 21:57:59 -0400102 return
103}
104
Patrick Williams213cb262021-08-07 19:21:33 -0500105do_install:append() {
Brad Bishopc342db32019-05-15 21:57:59 -0400106 for i in df mktemp nice printenv base64; do mv ${D}${bindir}/$i ${D}${bindir}/$i.${BPN}; done
107
108 install -d ${D}${base_bindir}
109 [ "${base_bindir}" != "${bindir}" ] && for i in ${base_bindir_progs}; do mv ${D}${bindir}/$i ${D}${base_bindir}/$i.${BPN}; done
110
111 install -d ${D}${sbindir}
112 [ "${sbindir}" != "${bindir}" ] && for i in ${sbindir_progs}; do mv ${D}${bindir}/$i ${D}${sbindir}/$i.${BPN}; done
113
114 # [ requires special handling because [.coreutils will cause the sed stuff
115 # in update-alternatives to fail, therefore use lbracket - the name used
116 # for the actual source file.
117 mv ${D}${bindir}/[ ${D}${bindir}/lbracket.${BPN}
118}
119
120inherit update-alternatives
121
122ALTERNATIVE_PRIORITY = "100"
123# Make hostname's priority higher than busybox but lower than net-tools
124ALTERNATIVE_PRIORITY[hostname] = "90"
Patrick Williams213cb262021-08-07 19:21:33 -0500125ALTERNATIVE:${PN} = "lbracket ${bindir_progs} ${base_bindir_progs} ${sbindir_progs} base32 base64 nice printenv mktemp df"
126ALTERNATIVE:${PN}-doc = "base64.1 nice.1 mktemp.1 df.1 groups.1 kill.1 uptime.1 stat.1 hostname.1"
Brad Bishopc342db32019-05-15 21:57:59 -0400127
128ALTERNATIVE_LINK_NAME[hostname.1] = "${mandir}/man1/hostname.1"
129
130ALTERNATIVE_LINK_NAME[base64] = "${base_bindir}/base64"
131ALTERNATIVE_TARGET[base64] = "${bindir}/base64.${BPN}"
132ALTERNATIVE_LINK_NAME[base64.1] = "${mandir}/man1/base64.1"
133
134ALTERNATIVE_LINK_NAME[mktemp] = "${base_bindir}/mktemp"
135ALTERNATIVE_TARGET[mktemp] = "${bindir}/mktemp.${BPN}"
136ALTERNATIVE_LINK_NAME[mktemp.1] = "${mandir}/man1/mktemp.1"
137
138ALTERNATIVE_LINK_NAME[df] = "${base_bindir}/df"
139ALTERNATIVE_TARGET[df] = "${bindir}/df.${BPN}"
140ALTERNATIVE_LINK_NAME[df.1] = "${mandir}/man1/df.1"
141
142ALTERNATIVE_LINK_NAME[nice] = "${base_bindir}/nice"
143ALTERNATIVE_TARGET[nice] = "${bindir}/nice.${BPN}"
144ALTERNATIVE_LINK_NAME[nice.1] = "${mandir}/man1/nice.1"
145
146ALTERNATIVE_LINK_NAME[printenv] = "${base_bindir}/printenv"
147ALTERNATIVE_TARGET[printenv] = "${bindir}/printenv.${BPN}"
148
149ALTERNATIVE_LINK_NAME[lbracket] = "${bindir}/["
150ALTERNATIVE_TARGET[lbracket] = "${bindir}/lbracket.${BPN}"
151
152ALTERNATIVE_LINK_NAME[groups.1] = "${mandir}/man1/groups.1"
153ALTERNATIVE_LINK_NAME[uptime.1] = "${mandir}/man1/uptime.1"
154ALTERNATIVE_LINK_NAME[kill.1] = "${mandir}/man1/kill.1"
155ALTERNATIVE_LINK_NAME[stat.1] = "${mandir}/man1/stat.1"
156
157python __anonymous() {
158 for prog in d.getVar('base_bindir_progs').split():
159 d.setVarFlag('ALTERNATIVE_LINK_NAME', prog, '%s/%s' % (d.getVar('base_bindir'), prog))
160
161 for prog in d.getVar('sbindir_progs').split():
162 d.setVarFlag('ALTERNATIVE_LINK_NAME', prog, '%s/%s' % (d.getVar('sbindir'), prog))
163}
164
165BBCLASSEXTEND = "native nativesdk"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500166
167inherit ptest
168
Patrick Williams213cb262021-08-07 19:21:33 -0500169RDEPENDS:${PN}-ptest += "bash findutils gawk liberror-perl make perl perl-modules python3-core sed shadow"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500170
171# -dev automatic dependencies fails as we don't want libmodule-build-perl-dev, its too heavy
172# may need tweaking if DEPENDS changes
Patrick Williams213cb262021-08-07 19:21:33 -0500173RRECOMMENDS:coreutils-dev[nodeprrecs] = "1"
174RRECOMMENDS:coreutils-dev = "acl-dev attr-dev gmp-dev libcap-dev bash-dev findutils-dev gawk-dev shadow-dev"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500175
176do_install_ptest () {
177 install -d ${D}${PTEST_PATH}/tests
178 cp -r ${S}/tests/* ${D}${PTEST_PATH}/tests
179 sed -i 's/ginstall/install/g' `grep -R ginstall ${D}${PTEST_PATH}/tests | awk -F: '{print $1}' | uniq`
180 install -d ${D}${PTEST_PATH}/build-aux
181 install ${S}/build-aux/test-driver ${D}${PTEST_PATH}/build-aux/
182 cp ${B}/Makefile ${D}${PTEST_PATH}/
183 cp ${S}/init.cfg ${D}${PTEST_PATH}/
184 cp -r ${B}/src ${D}${PTEST_PATH}/
185 cp -r ${S}/src/*.c ${D}${PTEST_PATH}/src
186 sed -i '/^VPATH/s/= .*$/= ./g' ${D}${PTEST_PATH}/Makefile
187 sed -i '/^PROGRAMS/s/^/#/g' ${D}${PTEST_PATH}/Makefile
188 sed -i '/^Makefile: /s/^.*$/Makefile:/g' ${D}${PTEST_PATH}/Makefile
189 sed -i '/^abs_srcdir/s/= .*$/= \$\{PWD\}/g' ${D}${PTEST_PATH}/Makefile
190 sed -i '/^abs_top_builddir/s/= .*$/= \$\{PWD\}/g' ${D}${PTEST_PATH}/Makefile
191 sed -i '/^abs_top_srcdir/s/= .*$/= \$\{PWD\}/g' ${D}${PTEST_PATH}/Makefile
192 sed -i '/^built_programs/s/ginstall/install/g' ${D}${PTEST_PATH}/Makefile
193 chmod -R 777 ${D}${PTEST_PATH}
194
195 # Disable subcase stty-pairs.sh, it will cause test framework hang
196 sed -i '/stty-pairs.sh/d' ${D}${PTEST_PATH}/Makefile
197
198 # Disable subcase tail-2/assert.sh as it has issues on 32-bit systems
199 sed -i '/assert.sh/d' ${D}${PTEST_PATH}/Makefile
200
201 # Tweak test d_type-check to use python3 instead of python
202 sed -i "1s@.*@#!/usr/bin/python3@" ${D}${PTEST_PATH}/tests/d_type-check
203 install ${B}/src/getlimits ${D}/${bindir}
204
205 # handle multilib
206 sed -i s:@libdir@:${libdir}:g ${D}${PTEST_PATH}/run-ptest
207}
208
Patrick Williams213cb262021-08-07 19:21:33 -0500209FILES:${PN}-ptest += "${bindir}/getlimits"
Andrew Geissler09209ee2020-12-13 08:44:15 -0600210
211# These are specific to Opensuse
212CVE_WHITELIST += "CVE-2013-0221 CVE-2013-0222 CVE-2013-0223"