blob: 50c4517da39e74f04bccb3f45b6dc061cb4f65ca [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001DESCRIPTION = "boot image with UEFI shell and tools"
Patrick Williams213cb262021-08-07 19:21:33 -05002COMPATIBLE_HOST:class-target='(i.86|x86_64).*'
Brad Bishop6e60e8b2018-02-01 10:27:11 -05003
4# For this image recipe, only the wic format with a
Brad Bishopd7bf8c12018-02-25 22:55:05 -05005# single vfat partition makes sense. Because we have no
6# boot loader and no rootfs partition, not additional
7# tools are needed for this .wks file.
Patrick Williams213cb262021-08-07 19:21:33 -05008IMAGE_FSTYPES:forcevariable = 'wic'
Brad Bishop6e60e8b2018-02-01 10:27:11 -05009WKS_FILE = "ovmf/ovmf-shell-image.wks"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050010WKS_FILE_DEPENDS = ""
11
Brad Bishop6e60e8b2018-02-01 10:27:11 -050012inherit image
13
14# We want a minimal image with just ovmf-shell-efi unpacked in it. We
15# avoid installing unnecessary stuff as much as possible, but some
16# things still get through and need to be removed.
17PACKAGE_INSTALL = "ovmf-shell-efi"
18LINGUAS_INSTALL = ""
19do_image () {
20 rm -rf `ls -d ${IMAGE_ROOTFS}/* | grep -v efi`
21}