blob: 9523aadd153a0b8ec16a3ad93cc19bec922b447c [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001#
2# Copyright (C) 2010 Intel Corporation
3#
4
5SUMMARY = "Self-hosting"
6DESCRIPTION = "Packages required to run the build system"
7PR = "r13"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05008
Brad Bishop00e122a2019-10-05 11:10:57 -04009PACKAGE_ARCH = "${TUNE_PKGARCH}"
10
Brad Bishop6dbb3162019-11-25 09:41:34 -050011inherit packagegroup features_check
Patrick Williamsc124f4f2015-09-15 14:41:29 -050012# rdepends on libx11-dev
13REQUIRED_DISTRO_FEATURES = "x11"
14
Brad Bishop6e60e8b2018-02-01 10:27:11 -050015# rdepends on libgl
16REQUIRED_DISTRO_FEATURES += "opengl"
17
Patrick Williamsc124f4f2015-09-15 14:41:29 -050018PACKAGES = "\
19 packagegroup-self-hosted \
20 packagegroup-self-hosted-debug \
21 packagegroup-self-hosted-sdk \
22 packagegroup-self-hosted-extended \
23 packagegroup-self-hosted-graphics \
24 packagegroup-self-hosted-host-tools \
25 "
26
Patrick Williams213cb262021-08-07 19:21:33 -050027RDEPENDS:packagegroup-self-hosted = "\
Patrick Williamsc124f4f2015-09-15 14:41:29 -050028 packagegroup-self-hosted-debug \
29 packagegroup-self-hosted-sdk \
30 packagegroup-self-hosted-extended \
31 packagegroup-self-hosted-graphics \
32 packagegroup-self-hosted-host-tools \
33 "
34
Patrick Williams213cb262021-08-07 19:21:33 -050035RDEPENDS:packagegroup-self-hosted-host-tools = "\
Patrick Williamsc124f4f2015-09-15 14:41:29 -050036 e2fsprogs \
37 e2fsprogs-e2fsck \
38 e2fsprogs-mke2fs \
39 e2fsprogs-tune2fs \
40 hdparm \
41 iptables \
Brad Bishop79641f22019-09-10 07:20:22 -040042 lsb-release \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050043 mc \
44 mc-fish \
45 mc-helpers \
46 mc-helpers-perl \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050047 parted \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050048 ${PSEUDO} \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050049 screen \
50 "
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050051PSEUDO = "pseudo"
Patrick Williams213cb262021-08-07 19:21:33 -050052PSEUDO:libc-musl = ""
Patrick Williamsc124f4f2015-09-15 14:41:29 -050053
Patrick Williams213cb262021-08-07 19:21:33 -050054RRECOMMENDS:packagegroup-self-hosted-host-tools = "\
Patrick Williamsc124f4f2015-09-15 14:41:29 -050055 kernel-module-tun \
56 kernel-module-iptable-raw \
57 kernel-module-iptable-nat \
58 kernel-module-iptable-mangle \
59 kernel-module-iptable-filter \
60 "
61
Patrick Williams213cb262021-08-07 19:21:33 -050062RDEPENDS:packagegroup-self-hosted-sdk = "\
Patrick Williamsc124f4f2015-09-15 14:41:29 -050063 autoconf \
64 automake \
65 binutils \
66 binutils-symlinks \
67 ccache \
68 coreutils \
69 cpp \
70 cpp-symlinks \
71 distcc \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050072 file \
73 findutils \
74 g++ \
75 g++-symlinks \
76 gcc \
77 gcc-symlinks \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050078 ldd \
79 less \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050080 libstdc++ \
81 libstdc++-dev \
82 libtool \
83 make \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050084 perl-module-re \
85 perl-module-text-wrap \
86 pkgconfig \
87 quilt \
88 sed \
89 "
Patrick Williams213cb262021-08-07 19:21:33 -050090RDEPENDS:packagegroup-self-hosted-sdk:append:mingw32 = "\
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080091 libssp \
92 libssp-dev \
93 libssp-staticdev \
94 "
95# rpcsvc-proto: for rpcgen
Patrick Williams213cb262021-08-07 19:21:33 -050096RDEPENDS:packagegroup-self-hosted-sdk:append:libc-glibc = "\
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050097 glibc-gconv-ibm850 \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050098 glibc-utils \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080099 rpcsvc-proto \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500100 "
Patrick Williams213cb262021-08-07 19:21:33 -0500101RDEPENDS:packagegroup-self-hosted-debug = " \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500102 gdb \
103 gdbserver \
104 rsync \
105 strace \
106 tcf-agent"
107
108
Patrick Williams213cb262021-08-07 19:21:33 -0500109RDEPENDS:packagegroup-self-hosted-extended = "\
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500110 bzip2 \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500111 chrpath \
112 cpio \
113 curl \
114 diffstat \
115 diffutils \
116 elfutils \
117 expat \
118 gawk \
119 gdbm \
120 gettext \
121 gettext-runtime \
122 git \
123 git-perltools \
124 grep \
125 groff \
126 gzip \
127 settings-daemon \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500128 libaio \
129 libusb1 \
130 libxml2 \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500131 lsof \
132 lzo \
133 man \
134 man-pages \
135 mdadm \
136 minicom \
137 mtools \
138 ncurses \
139 ncurses-terminfo-base \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500140 nfs-utils \
141 nfs-utils-client \
142 openssl \
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500143 openssh-scp \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500144 openssh-sftp-server \
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500145 openssh-ssh \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500146 opkg \
147 opkg-utils \
148 patch \
149 perl \
150 perl-dev \
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500151 perl-misc \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500152 perl-modules \
153 perl-pod \
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600154 python3 \
155 python3-modules \
156 python3-git \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500157 quota \
158 readline \
159 rpm \
160 setserial \
161 socat \
162 subversion \
163 sudo \
164 sysstat \
165 tar \
166 tcl \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500167 texinfo \
168 unzip \
169 usbutils \
170 watchdog \
171 wget \
172 which \
173 xinetd \
174 zip \
175 zlib \
176 xz \
177 "
178
179
Patrick Williams213cb262021-08-07 19:21:33 -0500180RDEPENDS:packagegroup-self-hosted-graphics = "\
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500181 builder \
182 libgl \
183 libgl-dev \
184 libglu \
185 libglu-dev \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500186 libx11-dev \
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600187 adwaita-icon-theme \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500188 xdg-utils \
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600189 l3afpad \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500190 pcmanfm \
191 vte \
192 "