blob: 698fd3585af07580fe8bebb377817e80439f92aa [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Sets up distcc for compilation on the target device"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "${SUMMARY}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05003
4LICENSE = "MIT"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05005LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05006
7SRC_URI = "file://distcc.sh"
8
9S = "${WORKDIR}"
10
11# Default to the host machine for a running qemu session
12DISTCC_HOSTS ?= "192.168.7.1"
13
14do_configure() {
15 sed -i "s%@DISTCC_HOSTS@%${DISTCC_HOSTS}%" distcc.sh
16}
17
18do_install() {
19 install -d ${D}${sysconfdir}/profile.d
20 install -m 0755 distcc.sh ${D}${sysconfdir}/profile.d/
21}
22
Patrick Williams213cb262021-08-07 19:21:33 -050023RDEPENDS:${PN} = "distcc"