blob: 2759ef8a53b0226711c309c03f1e16c492e87910 [file] [log] [blame]
Andrew Geissler09036742021-06-25 14:25:14 -05001SUMMARY = "Perl-cross build system"
2HOMEPAGE = "https://github.com/arsv/perl-cross"
3DESCRIPTION = "perl-cross provides configure script, top-level Makefile and some auxiliary files for perl, \
4with the primary emphasis on cross-compiling the source."
5SECTION = "devel"
6LICENSE = "Artistic-1.0 | GPL-1.0+"
7# README.md is taken from https://github.com/arsv/perl-cross/blob/master/README.md
8# but is not provided inside the release tarballs
9LIC_FILES_CHKSUM = "file://${WORKDIR}/README.md;md5=252fcce2026b765fee1ad74d2fb07a3b"
10
11inherit allarch
12
13SRC_URI = "https://github.com/arsv/perl-cross/releases/download/${PV}/perl-cross-${PV}.tar.gz;name=perl-cross \
14 file://README.md \
15 file://0001-configure_tool.sh-do-not-quote-the-argument-to-comma.patch \
16 file://0001-perl-cross-add-LDFLAGS-when-linking-libperl.patch \
17 file://0001-configure_path.sh-do-not-hardcode-prefix-lib-as-libr.patch \
18 file://determinism.patch \
19 file://0001-cnf-configure_func_sel.sh-disable-thread_safe_nl_lan.patch \
Andrew Geissler5f350902021-07-23 13:09:54 -040020 file://0001-Makefile-check-the-file-if-patched-or-not.patch \
Andrew Geissler09036742021-06-25 14:25:14 -050021 "
22UPSTREAM_CHECK_URI = "https://github.com/arsv/perl-cross/releases/"
23
24SRC_URI[perl-cross.sha256sum] = "4010f41870d64e3957b4b8ce70ebba10a7c4a3e86c5551acb4099c3fcbb37ce5"
25
26S = "${WORKDIR}/perl-cross-${PV}"
27
28do_configure () {
29}
30
31do_compile () {
32}
33
Patrick Williams213cb262021-08-07 19:21:33 -050034do_install:class-native() {
Andrew Geissler09036742021-06-25 14:25:14 -050035 mkdir -p ${D}/${datadir}/perl-cross/
36 cp -rf ${S}/* ${D}/${datadir}/perl-cross/
37}
38
39BBCLASSEXTEND = "native"
40