blob: 63c0fe97ff9510cc5b88bc9062866603bf9310f6 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "Download, build, install, upgrade, and uninstall Python packages"
Andrew Geisslerd25ed322020-06-27 00:28:28 -05002HOMEPAGE = "https://pypi.org/project/setuptools"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05003SECTION = "devel/python"
Patrick Williamsc0f7c042017-02-23 20:41:17 -06004LICENSE = "MIT"
Andrew Geisslerd1e89492021-02-12 15:35:20 -06005LIC_FILES_CHKSUM = "file://LICENSE;beginline=1;endline=19;md5=7a7126e068206290f3fe9f8d6c713ea6"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05006
Andrew Geissler635e0e42020-08-21 15:58:33 -05007inherit pypi setuptools3
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05008
Patrick Williams213cb262021-08-07 19:21:33 -05009SRC_URI:append:class-native = " file://0001-conditionally-do-not-fetch-code-by-easy_install.patch"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080010
Andrew Geissler5f350902021-07-23 13:09:54 -040011SRC_URI += "file://0001-change-shebang-to-python3.patch"
Andrew Geissler82c905d2020-04-13 13:39:40 -050012
Andrew Geissler5f350902021-07-23 13:09:54 -040013SRC_URI[sha256sum] = "cfca9c97e7eebbc8abe18d5e5e962a08dcad55bb63afddd82d681de4d22a597b"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050014
Brad Bishop316dfdd2018-06-25 12:45:53 -040015DEPENDS += "${PYTHON_PN}"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050016
Patrick Williams213cb262021-08-07 19:21:33 -050017RDEPENDS:${PN} = "\
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050018 ${PYTHON_PN}-2to3 \
Brad Bishop316dfdd2018-06-25 12:45:53 -040019 ${PYTHON_PN}-compile \
20 ${PYTHON_PN}-compression \
21 ${PYTHON_PN}-ctypes \
22 ${PYTHON_PN}-distutils \
23 ${PYTHON_PN}-email \
24 ${PYTHON_PN}-html \
Andrew Geisslerc182c622020-05-15 14:13:32 -050025 ${PYTHON_PN}-json \
Brad Bishop316dfdd2018-06-25 12:45:53 -040026 ${PYTHON_PN}-netserver \
27 ${PYTHON_PN}-numbers \
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050028 ${PYTHON_PN}-pickle \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060029 ${PYTHON_PN}-pkg-resources \
Brad Bishop316dfdd2018-06-25 12:45:53 -040030 ${PYTHON_PN}-pkgutil \
31 ${PYTHON_PN}-plistlib \
32 ${PYTHON_PN}-shell \
33 ${PYTHON_PN}-stringold \
34 ${PYTHON_PN}-threading \
35 ${PYTHON_PN}-unittest \
36 ${PYTHON_PN}-xml \
37"
Andrew Geissler635e0e42020-08-21 15:58:33 -050038
Patrick Williams213cb262021-08-07 19:21:33 -050039do_install:prepend() {
Patrick Williamsc0f7c042017-02-23 20:41:17 -060040 install -d ${D}${PYTHON_SITEPACKAGES_DIR}
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050041}
Brad Bishop316dfdd2018-06-25 12:45:53 -040042
43BBCLASSEXTEND = "native nativesdk"
Brad Bishop15ae2502019-06-18 21:44:24 -040044
45# The pkg-resources module can be used by itself, without the package downloader
46# and easy_install. Ship it in a separate package so that it can be used by
47# minimal distributions.
48PACKAGES =+ "${PYTHON_PN}-pkg-resources "
Patrick Williams213cb262021-08-07 19:21:33 -050049FILES:${PYTHON_PN}-pkg-resources = "${PYTHON_SITEPACKAGES_DIR}/pkg_resources/*"
50RDEPENDS:${PYTHON_PN}-pkg-resources = "\
Andrew Geissler5a43b432020-06-13 10:46:56 -050051 ${PYTHON_PN}-compression \
52 ${PYTHON_PN}-email \
53 ${PYTHON_PN}-plistlib \
54 ${PYTHON_PN}-pprint \
55"