blob: 87dc359439cd21f4a8625a12b666a8028447c1c7 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Subversion (svn) version control system client"
2HOMEPAGE = "http://subversion.apache.org"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06003DESCRIPTION = "Subversion is an open source version control system."
Andrew Geissler82c905d2020-04-13 13:39:40 -05004SECTION = "console/network"
5LICENSE = "Apache-2 & MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=6487ae7094d359fa90fb9c4096e52e2b"
7
8DEPENDS = "apr-util serf sqlite3 file lz4"
Patrick Williams213cb262021-08-07 19:21:33 -05009DEPENDS:append:class-native = " file-replacement-native"
Andrew Geissler82c905d2020-04-13 13:39:40 -050010
11SRC_URI = "${APACHE_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
12 file://disable_macos.patch \
13 file://0001-Fix-libtool-name-in-configure.ac.patch \
14 file://serfmacro.patch \
15 "
16
Andrew Geissler9b4d8b02021-02-19 12:26:16 -060017SRC_URI[sha256sum] = "2c5da93c255d2e5569fa91d92457fdb65396b0666fad4fd59b22e154d986e1a9"
Andrew Geissler82c905d2020-04-13 13:39:40 -050018
Andrew Geissler5a43b432020-06-13 10:46:56 -050019inherit autotools pkgconfig gettext python3native
Andrew Geissler82c905d2020-04-13 13:39:40 -050020
21CVE_PRODUCT = "apache:subversion"
22
23PACKAGECONFIG ?= ""
24
25PACKAGECONFIG[boost] = "--with-boost=${RECIPE_SYSROOT}${exec_prefix},--without-boost,boost"
26PACKAGECONFIG[sasl] = "--with-sasl,--without-sasl,cyrus-sasl"
27PACKAGECONFIG[gnome-keyring] = "--with-gnome-keyring,--without-gnome-keyring,glib-2.0 gnome-keyring"
28
29EXTRA_OECONF = " \
30 --with-apr=${STAGING_BINDIR_CROSS} \
31 --with-apr-util=${STAGING_BINDIR_CROSS} \
32 --without-apxs \
33 --without-berkeley-db \
34 --without-swig \
35 --disable-keychain \
36 --with-utf8proc=internal \
37 ac_cv_path_RUBY=none \
38"
39
40EXTRA_OEMAKE += "pkgconfig_dir=${libdir}/pkgconfig"
41
42acpaths = "-I build/ -I build/ac-macros/"
43
44CPPFLAGS += "-P"
45BUILD_CPPFLAGS += "-P"
46
Patrick Williams213cb262021-08-07 19:21:33 -050047do_configure:prepend () {
Andrew Geissler82c905d2020-04-13 13:39:40 -050048 rm -f ${S}/libtool
49 rm -f ${S}/build/libtool.m4 ${S}/build/ltmain.sh ${S}/build/ltoptions.m4 ${S}/build/ltsugar.m4 ${S}/build/ltversion.m4 ${S}/build/lt~obsolete.m4
50 rm -f ${S}/aclocal.m4
51 sed -i -e 's:with_sasl="/usr/local":with_sasl="${STAGING_DIR}":' ${S}/build/ac-macros/sasl.m4
52}
53
54#| x86_64-linux-libtool: install: warning: `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/build/subversion/libsvn_ra_local/libsvn_ra_local-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'| x86_64-linux-libtool: install: warning: `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/build/subversion/libsvn_repos/libsvn_repos-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'| /usr/bin/ld: cannot find -lsvn_delta-1| collect2: ld returned 1 exit status| x86_64-linux-libtool: install: warning: `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/build/subversion/libsvn_ra_svn/libsvn_ra_svn-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'| x86_64-linux-libtool: install: warning: `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/build/subversion/libsvn_ra_serf/libsvn_ra_serf-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'
55#| x86_64-linux-libtool: install: error: relink `libsvn_ra_serf-1.la' with the above command before installing it
56#| x86_64-linux-libtool: install: warning: `../../subversion/libsvn_repos/libsvn_repos-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'
57#| /home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/subversion-1.8.9/build-outputs.mk:1090: recipe for target 'install-serf-lib' failed
58#| make: *** [install-serf-lib] Error 1
59PARALLEL_MAKEINST = ""
60
Patrick Williams213cb262021-08-07 19:21:33 -050061RDEPENDS:${PN} = "serf"
Andrew Geissler82c905d2020-04-13 13:39:40 -050062
Andrew Geisslerb7d28612020-07-24 16:15:54 -050063BBCLASSEXTEND = "native nativesdk"