blob: 20ea3c25e309166e0bd0a55881cc9ef33d538378 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "GNU cpio is a program to manage archives of files"
2DESCRIPTION = "GNU cpio is a tool for creating and extracting archives, or copying files from one place to \
3another. It handles a number of cpio formats as well as reading and writing tar files."
4HOMEPAGE = "http://www.gnu.org/software/cpio/"
5SECTION = "base"
6LICENSE = "GPLv3"
7LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949"
8
9SRC_URI = "${GNU_MIRROR}/cpio/cpio-${PV}.tar.gz \
10 file://0001-Unset-need_charset_alias-when-building-for-musl.patch \
Andrew Geisslerc182c622020-05-15 14:13:32 -050011 file://0002-src-global.c-Remove-superfluous-declaration-of-progr.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050012 "
13
14SRC_URI[md5sum] = "389c5452d667c23b5eceb206f5000810"
15SRC_URI[sha256sum] = "e87470d9c984317f658567c03bfefb6b0c829ff17dbf6b0de48d71a4c8f3db88"
16
17inherit autotools gettext texinfo
18
William A. Kennington IIIac69b482021-06-02 12:28:27 -070019# Issue applies to use of cpio in SUSE/OBS, doesn't apply to us
20CVE_CHECK_WHITELIST += "CVE-2010-4226"
21
Andrew Geissler82c905d2020-04-13 13:39:40 -050022EXTRA_OECONF += "DEFAULT_RMT_DIR=${sbindir}"
23
24do_install () {
25 autotools_do_install
26 if [ "${base_bindir}" != "${bindir}" ]; then
27 install -d ${D}${base_bindir}/
28 mv "${D}${bindir}/cpio" "${D}${base_bindir}/cpio"
Andrew Geissler475cb722020-07-10 16:00:51 -050029 if [ "${sbindir}" != "${bindir}" ]; then
30 rmdir ${D}${bindir}/
31 fi
Andrew Geissler82c905d2020-04-13 13:39:40 -050032 fi
33
34 # Avoid conflicts with the version from tar
35 mv "${D}${mandir}/man8/rmt.8" "${D}${mandir}/man8/rmt-cpio.8"
36}
37
38PACKAGES =+ "${PN}-rmt"
39
Patrick Williams213cb262021-08-07 19:21:33 -050040FILES:${PN}-rmt = "${sbindir}/rmt*"
Andrew Geissler82c905d2020-04-13 13:39:40 -050041
42inherit update-alternatives
43
44ALTERNATIVE_PRIORITY = "100"
45
Patrick Williams213cb262021-08-07 19:21:33 -050046ALTERNATIVE:${PN} = "cpio"
47ALTERNATIVE:${PN}-rmt = "rmt"
Andrew Geissler82c905d2020-04-13 13:39:40 -050048
49ALTERNATIVE_LINK_NAME[cpio] = "${base_bindir}/cpio"
50
51ALTERNATIVE_PRIORITY[rmt] = "50"
52ALTERNATIVE_LINK_NAME[rmt] = "${sbindir}/rmt"
53
Andrew Geissler475cb722020-07-10 16:00:51 -050054BBCLASSEXTEND = "native nativesdk"