blob: aeff482f3ba9318541172dd48ae91238325229e2 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001DESCRIPTION = "This is a simple example recipe that cross-compiles a Go program."
2SECTION = "examples"
3HOMEPAGE = "https://golang.org/"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05004
Brad Bishopd7bf8c12018-02-25 22:55:05 -05005LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05007
Brad Bishopd7bf8c12018-02-25 22:55:05 -05008SRC_URI = "git://${GO_IMPORT}"
Andrew Geissler95ac1b82021-03-31 14:34:31 -05009SRCREV = "46695d81d1fae905a270fb7db8a4d11a334562fe"
Brad Bishop316dfdd2018-06-25 12:45:53 -040010UPSTREAM_CHECK_COMMITS = "1"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050011
Brad Bishopd7bf8c12018-02-25 22:55:05 -050012GO_IMPORT = "github.com/golang/example"
13GO_INSTALL = "${GO_IMPORT}/hello"
Andrew Geissler90fd73c2021-03-05 15:25:55 -060014GO_WORKDIR = "${GO_INSTALL}"
Andrew Geissler95ac1b82021-03-31 14:34:31 -050015export GO111MODULE="off"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050016
Andrew Geissler95ac1b82021-03-31 14:34:31 -050017inherit go
Brad Bishopd7bf8c12018-02-25 22:55:05 -050018
19# This is just to make clear where this example is
Patrick Williams213cb262021-08-07 19:21:33 -050020do_install:append() {
Brad Bishopd7bf8c12018-02-25 22:55:05 -050021 mv ${D}${bindir}/hello ${D}${bindir}/${BPN}
Brad Bishop6e60e8b2018-02-01 10:27:11 -050022}