blob: d5619675ef74792af704949688696b6ebb751f2b [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Midnight Commander is an ncurses based file manager"
2HOMEPAGE = "http://www.midnight-commander.org/"
Andrew Geissler95ac1b82021-03-31 14:34:31 -05003DESCRIPTION = "GNU Midnight Commander is a visual file manager, licensed under GNU General Public License and therefore qualifies as Free Software. It's a feature rich full-screen text mode application that allows you to copy, move and delete files and whole directory trees, search for files and run commands in the subshell. Internal viewer and editor are included."
Brad Bishop19323692019-04-05 15:28:33 -04004LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=270bbafe360e73f9840bd7981621f9c2"
6SECTION = "console/utils"
7DEPENDS = "ncurses glib-2.0 util-linux"
Patrick Williams213cb262021-08-07 19:21:33 -05008RDEPENDS:${PN} = "ncurses-terminfo-base"
9RRECOMMENDS:${PN} = "ncurses-terminfo"
Brad Bishop19323692019-04-05 15:28:33 -040010
11SRC_URI = "http://www.midnight-commander.org/downloads/${BPN}-${PV}.tar.bz2 \
12 file://0001-mc-replace-perl-w-with-use-warnings.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050013 file://nomandate.patch \
Brad Bishop19323692019-04-05 15:28:33 -040014 "
Andrew Geisslerd1e89492021-02-12 15:35:20 -060015SRC_URI[sha256sum] = "9d6358d0a351a455a1410aab57f33b6b48b0fcf31344b9a10b0ff497595979d1"
Brad Bishop19323692019-04-05 15:28:33 -040016
17inherit autotools gettext pkgconfig
18
19#
20# Both Samba (smb) and sftp require package delivered from meta-openembedded
21#
22PACKAGECONFIG ??= ""
23PACKAGECONFIG[smb] = "--enable-vfs-smb,--disable-vfs-smb,samba,"
24PACKAGECONFIG[sftp] = "--enable-vfs-sftp,--disable-vfs-sftp,libssh2,"
25
Patrick Williams213cb262021-08-07 19:21:33 -050026CFLAGS:append:libc-musl = ' -DNCURSES_WIDECHAR=1 '
Brad Bishop1d80a2e2019-11-15 16:35:03 -050027EXTRA_OECONF = "--with-screen=ncurses --without-gpm-mouse --without-x --disable-configure-args"
Brad Bishop19323692019-04-05 15:28:33 -040028
29CACHED_CONFIGUREVARS += "ac_cv_path_PERL='/usr/bin/env perl'"
Brad Bishop1d80a2e2019-11-15 16:35:03 -050030CACHED_CONFIGUREVARS += "ac_cv_path_PYTHON='/usr/bin/env python'"
31CACHED_CONFIGUREVARS += "ac_cv_path_GREP='/usr/bin/env grep'"
Andrew Geissler82c905d2020-04-13 13:39:40 -050032CACHED_CONFIGUREVARS += "mc_cv_have_zipinfo=yes"
Brad Bishop19323692019-04-05 15:28:33 -040033
Patrick Williams213cb262021-08-07 19:21:33 -050034do_install:append () {
Brad Bishop19323692019-04-05 15:28:33 -040035 sed -i -e '1s,#!.*perl,#!${bindir}/env perl,' ${D}${libexecdir}/mc/extfs.d/*
36
37 rm ${D}${libexecdir}/mc/extfs.d/s3+ ${D}${libexecdir}/mc/extfs.d/uc1541
38}
39
40PACKAGES =+ "${BPN}-helpers-perl ${BPN}-helpers ${BPN}-fish"
41
Patrick Williams213cb262021-08-07 19:21:33 -050042SUMMARY:${BPN}-helpers-perl = "Midnight Commander Perl-based helper scripts"
43FILES:${BPN}-helpers-perl = "${libexecdir}/mc/extfs.d/a+ ${libexecdir}/mc/extfs.d/apt+ \
Brad Bishop19323692019-04-05 15:28:33 -040044 ${libexecdir}/mc/extfs.d/deb ${libexecdir}/mc/extfs.d/deba \
45 ${libexecdir}/mc/extfs.d/debd ${libexecdir}/mc/extfs.d/dpkg+ \
46 ${libexecdir}/mc/extfs.d/mailfs ${libexecdir}/mc/extfs.d/patchfs \
47 ${libexecdir}/mc/extfs.d/rpms+ ${libexecdir}/mc/extfs.d/ulib \
48 ${libexecdir}/mc/extfs.d/uzip"
Patrick Williams213cb262021-08-07 19:21:33 -050049RDEPENDS:${BPN}-helpers-perl = "perl"
Brad Bishop19323692019-04-05 15:28:33 -040050
Patrick Williams213cb262021-08-07 19:21:33 -050051SUMMARY:${BPN}-helpers = "Midnight Commander shell helper scripts"
52FILES:${BPN}-helpers = "${libexecdir}/mc/extfs.d/* ${libexecdir}/mc/ext.d/*"
Brad Bishop19323692019-04-05 15:28:33 -040053
Patrick Williams213cb262021-08-07 19:21:33 -050054SUMMARY:${BPN}-fish = "Midnight Commander Fish scripts"
55FILES:${BPN}-fish = "${libexecdir}/mc/fish"