blob: b17cba4a7891bc155b55029b029323926be4571e [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001#
2# Copyright (C) 2019 Konsulko Group
3#
4
5SUMMARY = "Full-featured set of base utils"
6DESCRIPTION = "Package group bringing in packages needed to provide much of the base utils type functionality found in busybox"
7
Brad Bishop08902b02019-08-20 09:16:51 -04008PACKAGE_ARCH = "${MACHINE_ARCH}"
9
Brad Bishop19323692019-04-05 15:28:33 -040010inherit packagegroup
11
12VIRTUAL-RUNTIME_vim ?= "vim-tiny"
13
Brad Bishopc68388fc2019-08-26 01:33:31 -040014PACKAGE_ARCH = "${MACHINE_ARCH}"
15
Patrick Williams213cb262021-08-07 19:21:33 -050016RDEPENDS:${PN} = "\
Brad Bishop19323692019-04-05 15:28:33 -040017 base-passwd \
18 bash \
19 bind-utils \
20 bzip2 \
21 coreutils \
22 cpio \
23 ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "", "debianutils-run-parts", d)} \
Andrew Geisslerc9f78652020-09-18 14:11:35 -050024 dhcpcd \
25 ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "", "kea", d)} \
Brad Bishop19323692019-04-05 15:28:33 -040026 diffutils \
27 ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "", "dpkg-start-stop", d)} \
28 e2fsprogs \
29 ed \
30 file \
31 findutils \
32 gawk \
33 grep \
34 gzip \
35 ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "", "ifupdown", d)} \
36 inetutils \
37 inetutils-ping \
38 inetutils-telnet \
39 inetutils-tftp \
40 inetutils-traceroute \
41 iproute2 \
42 ${@bb.utils.contains("MACHINE_FEATURES", "keyboard", "kbd", "", d)} \
43 kmod \
44 less \
45 ncurses-tools \
46 net-tools \
47 parted \
48 patch \
49 procps \
50 psmisc \
51 sed \
52 shadow-base \
53 tar \
54 time \
55 unzip \
56 util-linux \
57 ${VIRTUAL-RUNTIME_vim} \
58 wget \
59 which \
60 xz \
61 "