blob: 3fa89dec9a65fe533dea082f8cba3b4e1c1560ad [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "PBZIP2 is a parallel implementation of bzip2"
2DESCRIPTION = "PBZIP2 is a parallel implementation of the bzip2 block-sorting \
3file compressor that uses pthreads and achieves near-linear speedup on SMP \
4machines. The output of this version is fully compatible with bzip2 v1.0.2 or \
5newer (ie: anything compressed with pbzip2 can be decompressed with bzip2)."
Andrew Geissler6ce62a22020-11-30 19:58:47 -06006HOMEPAGE = "https://launchpad.net/pbzip2/"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05007SECTION = "console/utils"
Andrew Geissler82c905d2020-04-13 13:39:40 -05008LICENSE = "bzip2-1.0.6"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05009LIC_FILES_CHKSUM = "file://COPYING;md5=398b8832c6f840cfebd20ab2be6a3743"
10
11DEPENDS = "bzip2"
Patrick Williams213cb262021-08-07 19:21:33 -050012DEPENDS:append:class-native = " bzip2-replacement-native"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050013
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014SRC_URI = "https://launchpad.net/${BPN}/1.1/${PV}/+download/${BP}.tar.gz \
15 file://0001-pbzip2-Fix-invalid-suffix-on-literal-C-11-warning.patch \
16 "
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050017
18SRC_URI[md5sum] = "4cb87da2dba05540afce162f34b3a9a6"
19SRC_URI[sha256sum] = "8fd13eaaa266f7ee91f85c1ea97c86d9c9cc985969db9059cdebcb1e1b7bdbe6"
20
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080021UPSTREAM_CHECK_URI = "https://launchpad.net/pbzip2/+milestones"
22UPSTREAM_CHECK_REGEX = "pbzip2 (?P<pver>\d+(\.\d+)+)"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050023
24EXTRA_OEMAKE = "CXX='${CXX} ${CXXFLAGS}' LDFLAGS='${LDFLAGS}'"
25
26do_install() {
27 install -d ${D}${bindir}
28 install -m 0755 pbzip2 ${D}${bindir}/
29}
30
Andrew Geissler635e0e42020-08-21 15:58:33 -050031BBCLASSEXTEND = "native nativesdk"