blob: 9aa6fd050dff5cd15f4796cfe03598d67972eaad [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Perl module for using and building Perl SAX2 XML processors"
2HOMEPAGE = "http://search.cpan.org/dist/XML-SAX/"
3DESCRIPTION = "XML::SAX consists of several framework classes for using and \
4building Perl SAX2 XML parsers, filters, and drivers. It is designed \
5around the need to be able to "plug in" different SAX parsers to an \
6application without requiring programmer intervention. Those of you \
7familiar with the DBI will be right at home. Some of the designs \
8come from the Java JAXP specification (SAX part), only without the \
9javaness."
10
11SECTION = "libs"
12LICENSE = "Artistic-1.0 | GPL-1.0+"
13DEPENDS += "libxml-namespacesupport-perl-native"
Patrick Williams213cb262021-08-07 19:21:33 -050014RDEPENDS:${PN} += "libxml-namespacesupport-perl libxml-sax-base-perl perl-module-file-temp"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015
16LIC_FILES_CHKSUM = "file://LICENSE;md5=65c4cd8f39c24c7135ed70dacbcb09e3"
17
18SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GR/GRANTM/XML-SAX-${PV}.tar.gz"
19
Brad Bishopf3fd2882019-06-21 08:06:37 -040020SRC_URI[md5sum] = "b62e3754523695c7f5bbcafa3676a38d"
21SRC_URI[sha256sum] = "4506c387043aa6a77b455f00f57409f3720aa7e553495ab2535263b4ed1ea12a"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080022
23S = "${WORKDIR}/XML-SAX-${PV}"
24
25inherit cpan ptest-perl
26
27do_install_ptest() {
28 cp -r ${B}/testfiles ${D}${PTEST_PATH}
29 chown -R root:root ${D}${PTEST_PATH}/testfiles
30}
31
Patrick Williams213cb262021-08-07 19:21:33 -050032RDEPENDS:${PN} += "perl-module-encode perl-module-perlio"
Brad Bishopf3fd2882019-06-21 08:06:37 -040033
Patrick Williams213cb262021-08-07 19:21:33 -050034RDEPENDS:${PN}-ptest += " \
Brad Bishopf3fd2882019-06-21 08:06:37 -040035 perl-module-base \
36 perl-module-encode-byte \
37 perl-module-encode-unicode \
38 perl-module-fatal \
39 perl-module-test \
40"
Brad Bishop15ae2502019-06-18 21:44:24 -040041
Brad Bishop19323692019-04-05 15:28:33 -040042BBCLASSEXTEND = "native nativesdk"