blob: 678632a8142a1b9bb0530a0b9fba7d8549a507c0 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001# Copyright (C) 2018 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "rpcsvc protocol definitions from glibc"
5
6DESCRIPTION = "This package contains rpcsvc proto.x files from glibc, which are\
7missing in libtirpc. Additional it contains rpcgen, which is needed\
8to create header files and sources from protocol files.\
9This package is only needed, if glibc is installed without the\
10deprecated sunrpc functionality and libtirpc should replace it."
11
12HOMEPAGE = "https://github.com/thkukuk/rpcsvc-proto"
13LICENSE = "BSD-3-Clause"
14LIC_FILES_CHKSUM = "file://COPYING;md5=0daaf958d5531ab86169ec6e275e1517"
15SECTION = "libs"
16DEPENDS += "rpcsvc-proto-native"
17
Andrew Geisslerb7d28612020-07-24 16:15:54 -050018PV = "1.4.2"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080019
Andrew Geisslerb7d28612020-07-24 16:15:54 -050020SRCREV = "6f54e54455c073d08a56ea627c6cd2355a40eb53"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080021
22SRC_URI = "git://github.com/thkukuk/${BPN} \
23 file://0001-Use-cross-compiled-rpcgen.patch \
24 "
25
26S = "${WORKDIR}/git"
27
Andrew Geisslerc182c622020-05-15 14:13:32 -050028inherit autotools gettext
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080029
Patrick Williams213cb262021-08-07 19:21:33 -050030EXTRA_OEMAKE:class-native = " -C rpcgen"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080031
Patrick Williams213cb262021-08-07 19:21:33 -050032do_configure:prepend() {
Andrew Geisslerc182c622020-05-15 14:13:32 -050033 touch ${S}/ABOUT-NLS
34}
35
Patrick Williams213cb262021-08-07 19:21:33 -050036do_install:append() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080037 # They come from quota recipe
38 rm -rf ${D}${includedir}/rpcsvc/rquota.[hx]
39}
40
41BBCLASSEXTEND += "native nativesdk"