blob: afc9ddf96c252ef1dfde35f573080cbb8daecad5 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "System load testing utility"
2DESCRIPTION = "Deliberately simple workload generator for POSIX systems. It \
3imposes a configurable amount of CPU, memory, I/O, and disk stress on the system."
4HOMEPAGE = "https://kernel.ubuntu.com/~cking/stress-ng/"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8SRC_URI = "https://kernel.ubuntu.com/~cking/tarballs/${BPN}/${BP}.tar.xz \
9 file://0001-Do-not-preserve-ownership-when-installing-example-jo.patch \
Patrick Williams213cb262021-08-07 19:21:33 -050010 file://0001-Detemine-minimal-stack-size-via-sysconf-then-PTHREAD.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050011 "
Andrew Geissler5f350902021-07-23 13:09:54 -040012SRC_URI[sha256sum] = "f27af50f6f2308e707fef927674bdd209a046b116734281b792aeca35a4e4499"
Andrew Geissler82c905d2020-04-13 13:39:40 -050013
14DEPENDS = "coreutils-native"
15
16PROVIDES = "stress"
Patrick Williams213cb262021-08-07 19:21:33 -050017RPROVIDES:${PN} = "stress"
18RREPLACES:${PN} = "stress"
19RCONFLICTS:${PN} = "stress"
Andrew Geissler82c905d2020-04-13 13:39:40 -050020
21inherit bash-completion
22
23do_install() {
24 oe_runmake DESTDIR=${D} install
Andrew Geissler635e0e42020-08-21 15:58:33 -050025 ln -s stress-ng ${D}${bindir}/stress
Andrew Geissler82c905d2020-04-13 13:39:40 -050026}