blob: e0ead59da68e98c1ef9798828131720289c97381 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001DESCRIPTION = "There are two major versions of the PCRE library. The \
2newest version is PCRE2, which is a re-working of the original PCRE \
3library to provide an entirely new API. The original, very widely \
4deployed PCRE library's API and feature are stable, future releases \
5 will be for bugfixes only. All new future features will be to PCRE2, \
6not the original PCRE 8.x series."
7SUMMARY = "Perl Compatible Regular Expressions version 2"
8HOMEPAGE = "http://www.pcre.org"
9SECTION = "devel"
10LICENSE = "BSD-3-Clause"
William A. Kennington IIIac69b482021-06-02 12:28:27 -070011LIC_FILES_CHKSUM = "file://LICENCE;md5=6b3022283c9a79238d521848ea9dcb4d"
Andrew Geissler82c905d2020-04-13 13:39:40 -050012
Andrew Geissler4ed12e12020-06-05 18:00:41 -050013SRC_URI = "https://ftp.pcre.org/pub/pcre/pcre2-${PV}.tar.bz2"
Andrew Geissler82c905d2020-04-13 13:39:40 -050014
William A. Kennington IIIac69b482021-06-02 12:28:27 -070015SRC_URI[sha256sum] = "4d95a96e8b80529893b4562be12648d798b957b1ba1aae39606bbc2ab956d270"
Andrew Geissler82c905d2020-04-13 13:39:40 -050016
17CVE_PRODUCT = "pcre2"
18
19S = "${WORKDIR}/pcre2-${PV}"
20
21PROVIDES += "pcre2"
22DEPENDS += "bzip2 zlib"
23
24BINCONFIG = "${bindir}/pcre2-config"
25
26inherit autotools binconfig-disabled
27
28EXTRA_OECONF = "\
29 --enable-newline-is-lf \
Andrew Geissler82c905d2020-04-13 13:39:40 -050030 --with-link-size=2 \
31 --with-match-limit=10000000 \
32 --enable-pcre2-16 \
33 --enable-pcre2-32 \
34"
Andrew Geissler82c905d2020-04-13 13:39:40 -050035CFLAGS += "-D_REENTRANT"
Patrick Williams213cb262021-08-07 19:21:33 -050036CXXFLAGS:append:powerpc = " -lstdc++"
Andrew Geissler82c905d2020-04-13 13:39:40 -050037
Andrew Geissler82c905d2020-04-13 13:39:40 -050038PACKAGES =+ "libpcre2-16 libpcre2-32 pcre2grep pcre2grep-doc pcre2test pcre2test-doc"
39
Patrick Williams213cb262021-08-07 19:21:33 -050040SUMMARY:pcre2grep = "grep utility that uses perl 5 compatible regexes"
41SUMMARY:pcre2grep-doc = "grep utility that uses perl 5 compatible regexes - docs"
42SUMMARY:pcre2test = "program for testing Perl-comatible regular expressions"
43SUMMARY:pcre2test-doc = "program for testing Perl-comatible regular expressions - docs"
Andrew Geissler82c905d2020-04-13 13:39:40 -050044
Patrick Williams213cb262021-08-07 19:21:33 -050045FILES:libpcre2-16 = "${libdir}/libpcre2-16.so.*"
46FILES:libpcre2-32 = "${libdir}/libpcre2-32.so.*"
47FILES:pcre2grep = "${bindir}/pcre2grep"
48FILES:pcre2grep-doc = "${mandir}/man1/pcre2grep.1"
49FILES:pcre2test = "${bindir}/pcre2test"
50FILES:pcre2test-doc = "${mandir}/man1/pcre2test.1"
Andrew Geissler82c905d2020-04-13 13:39:40 -050051
52BBCLASSEXTEND = "native nativesdk"