blob: 465f03493337202a6ccee56063de31c3f461a6f1 [file] [log] [blame]
Brad Bishopbec4ebc2022-08-03 09:55:16 -04001FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
2
3#
4# Corstone-500 MACHINE
5#
6SRC_URI:append:corstone500 = " \
7 file://0001-armv7-adding-generic-timer-access-through-MMIO.patch \
8 file://0002-board-arm-add-corstone500-board.patch"
9
10#
11# Corstone1000 64-bit machines
12#
13DEPENDS:append:corstone1000 = " gnutls-native"
14CORSTONE1000_DEVICE_TREE:corstone1000-mps3 = "corstone1000-mps3"
15CORSTONE1000_DEVICE_TREE:corstone1000-fvp = "corstone1000-fvp"
16EXTRA_OEMAKE:append:corstone1000 = ' DEVICE_TREE=${CORSTONE1000_DEVICE_TREE}'
17
18SYSROOT_DIRS:append:corstone1000 = " /boot"
19
20SRC_URI:append:corstone1000 = " \
Patrick Williams8dd68482022-10-04 07:57:18 -050021 file://0001-cmd-load-add-load-command-for-memory-mapped.patch \
22 file://0002-arm-add-support-to-corstone1000-platform.patch \
23 file://0003-usb-common-move-urb-code-to-common.patch \
24 file://0004-usb-add-isp1760-family-driver.patch \
25 file://0005-corstone1000-enable-isp1763-usb-controller.patch \
26 file://0006-arm64-smccc-add-support-for-SMCCCv1.2-x0-x17-registe.patch \
27 file://0007-arm64-smccc-clear-the-Xn-registers-after-SMC-calls.patch \
28 file://0008-lib-uuid-introduce-be_uuid_str_to_le_bin-function.patch \
29 file://0009-arm_ffa-introduce-Arm-FF-A-low-level-driver.patch \
30 file://0010-arm_ffa-introduce-armffa-command.patch \
31 file://0011-arm_ffa-introduce-the-FF-A-Sandbox-driver.patch \
32 file://0012-arm_ffa-introduce-Sandbox-test-cases-for-UCLASS_FFA.patch \
33 file://0013-arm_ffa-introduce-armffa-command-Sandbox-test.patch \
34 file://0014-arm_ffa-introduce-FF-A-MM-communication.patch \
35 file://0015-arm_ffa-corstone1000-enable-FF-A-and-MM-support.patch \
36 file://0016-efi-corstone1000-introduce-EFI-capsule-update.patch \
37 file://0017-corstone1000-Update-FFA-shared-buffer-address.patch \
38 file://0018-arm-corstone1000-fix-unrecognized-filesystem-type.patch \
39 file://0019-efi_capsule-corstone1000-pass-interface-id-and-buffe.patch \
40 file://0020-efi_boottime-corstone1000-pass-interface-id-and-kern.patch \
41 file://0021-efi_loader-corstone1000-remove-guid-check-from-corst.patch \
42 file://0022-efi_loader-populate-ESRT-table-if-EFI_ESRT-config-op.patch \
43 file://0023-efi_firmware-add-get_image_info-for-corstone1000.patch \
44 file://0024-efi_loader-send-bootcomplete-message-to-secure-encla.patch \
45 file://0025-efi_loader-fix-null-pointer-exception-with-get_image.patch \
46 file://0026-arm-corstone1000-add-mmc-for-fvp.patch \
47 file://0027-corstone1000-use-a-compressed-kernel.patch \
48 file://0028-Introduce-external-sys-driver-to-device-tree.patch \
49 file://0029-Add-mhu-and-rpmsg-client-to-u-boot-device-tree.patch \
Patrick Williams2194f502022-10-16 14:26:09 -050050 file://0030-arm-corstone1000-esrt-support.patch \
51 "
Brad Bishopbec4ebc2022-08-03 09:55:16 -040052
53#
54# FVP BASE
55#
56SRC_URI:append:fvp-base = " file://bootargs.cfg"
57
58#
59# FVP BASE ARM32
60#
61SRC_URI:append:fvp-base-arm32 = " file://0001-Add-vexpress_aemv8a_aarch32-variant.patch \
62 file://0002-Revert-vexpress64-Enable-OF_CONTROL-and-OF_BOARD-for.patch \
63 "
64
65#
66# FVP BASER
67#
68SRC_URI:append:fvp-baser-aemv8r64 = " \
69 file://0001-armv8-Add-ARMv8-MPU-configuration-logic.patch \
70 file://0002-vexpress64-add-MPU-memory-map-for-the-BASER_FVP.patch \
71 file://0003-armv8-Allow-disabling-exception-vectors-on-non-SPL-b.patch \
72 file://0004-armv8-ARMV8_SWITCH_TO_EL1-improvements.patch \
73 file://0005-armv8-Make-disabling-HVC-configurable-when-switching.patch \
74 file://0006-vexpress64-Do-not-set-COUNTER_FREQUENCY.patch \
75 file://0007-vexpress64-Enable-LIBFDT_OVERLAY-in-the-vexpress_aem.patch \
76 file://0008-armv8-Allow-PRBAR-MPU-attributes-to-be-configured.patch \
77 file://0009-armv8-Enable-icache-when-switching-exception-levels-.patch \
78 "
79
80
81#
82# Juno Machines
83#
84SRC_URI:append:juno = " file://0001-arm-juno-add-custom-bootcmd-to-autoboot-from-uEnv.tx.patch"
85
86
87#
88# TC0 and TC1 MACHINES
89#
90SRC_URI:append:tc = " \
91 file://bootargs.cfg \
92 file://0001-arm-total_compute-update-secure-dram-size.patch \
Patrick Williams8dd68482022-10-04 07:57:18 -050093 file://0002-arm_ffa-introducing-Arm-FF-A-low-level-driver.patch \
94 file://0003-arm-total_compute-enable-psci.patch \
95 file://0004-arm_ffa-rxtx_map-should-use-64-bit-calls.patch \
96 file://0005-efi_firmware-add-new-fmp-driver-that-supports-arm-fw.patch \
97 file://0006-arm-total_compute-enable-capsule-update.patch \
98 file://0007-arm_ffa-unmap-rxtx-buffer-before-exiting-u-boot.patch \
Brad Bishopbec4ebc2022-08-03 09:55:16 -040099 "