blob: 45a1578be7c6a3d05ca9e9f87659c32aac1cb1a5 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "File system QA test suite"
2LICENSE = "GPL-2.0-only"
3LIC_FILES_CHKSUM = "file://LICENSES/GPL-2.0;md5=74274e8a218423e49eefdea80bc55038"
4
5SRCREV_FORMAT = "xfstests_unionmount"
6
Andrew Geissler87f5cff2022-09-30 13:13:31 -05007SRC_URI = "git://git.kernel.org/pub/scm/fs/xfs/xfstests-dev.git;branch=master;name=xfstests \
8 git://github.com/amir73il/unionmount-testsuite.git;branch=master;protocol=https;name=unionmount;destsuffix=unionmount-testsuite \
9 file://0001-Add-a-return-type-to-aio_rw.patch \
10 file://0002-Drop-detached_mounts_propagation-and-remove-sys-moun.patch \
11 "
Patrick Williams92b42cb2022-09-03 06:53:57 -050012
Patrick Williams2194f502022-10-16 14:26:09 -050013SRCREV_xfstests = "e5555e75ba199d153f4dfb81496a891263ec9bdd"
Patrick Williams92b42cb2022-09-03 06:53:57 -050014SRCREV_unionmount = "e3825b16b46f4c4574a1a69909944c059835f914"
15
16S = "${WORKDIR}/git"
17
18inherit autotools-brokensep useradd
19
20DEPENDS += "xfsprogs acl"
21RDEPENDS:${PN} += "\
22 bash \
23 bc \
24 coreutils \
25 e2fsprogs \
26 e2fsprogs-tune2fs \
27 e2fsprogs-resize2fs \
28 libaio \
29 libcap-bin \
30 overlayfs-progs \
31 perl \
32 python3 \
33 python3-core \
34 xfsprogs \
35 acl \
36"
37
38USERADD_PACKAGES = "${PN}"
39# these users are necessary to run the tests
40USERADD_PARAM:${PN} = "-U -m fsgqa; -N 123456-fsgqa; -N fsgqa2"
41
42EXTRA_OECONF = "INSTALL_USER=root INSTALL_GROUP=root"
43
44# install-sh script in the project is outdated
45# we use the one from the latest libtool to solve installation issues
46# It looks like the upstream is not interested in having it fixed :(
47# https://www.spinics.net/lists/fstests/msg16981.html
48do_configure:prepend() {
49 cp ${STAGING_DIR_NATIVE}${datadir}/libtool/build-aux/install-sh ${B}
50}
51
52do_install:append() {
53 unionmount_target_dir=${D}/usr/xfstests/unionmount-testsuite
54 install -d ${D}/usr/xfstests/unionmount-testsuite/tests
55 install -D ${WORKDIR}/unionmount-testsuite/tests/* -t $unionmount_target_dir/tests
56 install ${WORKDIR}/unionmount-testsuite/*.py -t $unionmount_target_dir
57 install ${WORKDIR}/unionmount-testsuite/run -t $unionmount_target_dir
58 install ${WORKDIR}/unionmount-testsuite/README -t $unionmount_target_dir
59}
60
61FILES:${PN} += "\
62 /usr/xfstests \
63"