blob: eed00fce0247a7a867059d4354c14ea757b89683 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001DESCRIPTION = "Blueman is a GTK+ Bluetooth Manager"
2LICENSE = "GPL-3.0-only"
3LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
4
5DEPENDS = "gtk+3 glib-2.0 bluez5 python3-pygobject python3-cython-native"
6
7inherit meson gettext systemd gsettings pkgconfig python3native gtk-icon-cache
8
9SRC_URI = " \
Patrick Williams2194f502022-10-16 14:26:09 -050010 git://github.com/blueman-project/blueman.git;protocol=https;branch=2-3-stable \
Andrew Geissler9aee5002022-03-30 16:27:02 +000011 file://0001-Search-for-cython3.patch \
12 file://0002-fix-fail-to-enable-bluetooth.patch \
Patrick Williamsde0582f2022-04-08 10:23:27 -050013 file://0001-meson-add-pythoninstalldir-option.patch \
Andrew Geissler9aee5002022-03-30 16:27:02 +000014"
Patrick Williams2194f502022-10-16 14:26:09 -050015S = "${WORKDIR}/git"
16SRCREV = "4275c35ffe372c3b194080726fbe1c99f974360f"
Andrew Geissler9aee5002022-03-30 16:27:02 +000017
Patrick Williams2194f502022-10-16 14:26:09 -050018EXTRA_OEMESON = "-Druntime_deps_check=false -Dpythoninstalldir=${@noprefix('PYTHON_SITEPACKAGES_DIR', d)}"
Andrew Geissler9aee5002022-03-30 16:27:02 +000019
20SYSTEMD_SERVICE:${PN} = "${BPN}-mechanism.service"
21SYSTEMD_AUTO_ENABLE:${PN} = "disable"
22
Andrew Geissler615f2f12022-07-15 14:00:58 -050023RRECOMMENDS:${PN} += "adwaita-icon-theme"
Andrew Geissler9aee5002022-03-30 16:27:02 +000024RDEPENDS:${PN} += " \
25 python3-core \
26 python3-dbus \
27 python3-pygobject \
28 python3-terminal \
29 packagegroup-tools-bluetooth \
30"
31
32PACKAGECONFIG ??= " \
33 ${@bb.utils.filter('DISTRO_FEATURES', 'polkit pulseaudio ', d)} \
34 thunar \
35"
36PACKAGECONFIG[thunar] = "-Dthunar-sendto=true,-Dthunar-sendto=false"
37PACKAGECONFIG[pulseaudio] = "-Dpulseaudio=true,-Dpulseaudio=false"
38PACKAGECONFIG[polkit] = "-Dpolicykit=true,-Dpolicykit=false"
39
40FILES:${PN} += " \
41 ${datadir} \
42 ${systemd_user_unitdir} \
43 ${PYTHON_SITEPACKAGES_DIR} \
44"
45
46# In code, path to python is a variable that is replaced with path to native version of it
47# during the configure stage, e.g ../recipe-sysroot-native/usr/bin/python3-native/python3.
48# Replace it with #!/usr/bin/env python3
49do_install:append() {
50 sed -i "1s/.*/#!\/usr\/bin\/env python3/" ${D}${prefix}/libexec/blueman-rfcomm-watcher \
51 ${D}${prefix}/libexec/blueman-mechanism \
52 ${D}${bindir}/blueman-adapters \
53 ${D}${bindir}/blueman-applet \
54 ${D}${bindir}/blueman-manager \
55 ${D}${bindir}/blueman-sendto \
56 ${D}${bindir}/blueman-services \
57 ${D}${bindir}/blueman-tray
58}
59