blob: 266d43aa6f267e57dfe93760886b7601380ad5c0 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001DESCRIPTION = "strongSwan is an OpenSource IPsec implementation for the \
2Linux operating system."
3SUMMARY = "strongSwan is an OpenSource IPsec implementation"
4HOMEPAGE = "http://www.strongswan.org"
5SECTION = "net"
6LICENSE = "GPL-2.0-only"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
8DEPENDS = "flex-native flex bison-native"
9DEPENDS:append = "${@bb.utils.contains('DISTRO_FEATURES', 'tpm2', ' tpm2-tss', '', d)}"
10
11SRC_URI = "http://download.strongswan.org/strongswan-${PV}.tar.bz2 \
12 "
13
Patrick Williams2194f502022-10-16 14:26:09 -050014SRC_URI[sha256sum] = "d3303a43c0bd7b75a12b64855e8edcb53696f06190364f26d1533bde1f2e453c"
Patrick Williams92b42cb2022-09-03 06:53:57 -050015
16UPSTREAM_CHECK_REGEX = "strongswan-(?P<pver>\d+(\.\d+)+)\.tar"
17
18EXTRA_OECONF = " \
19 --without-lib-prefix \
20 --with-dev-headers=${includedir}/strongswan \
21"
22
23EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_unitdir}/system/', '--without-systemdsystemunitdir', d)}"
24
25PACKAGECONFIG ?= "curl gmp openssl sqlite3 swanctl curve25519\
26 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd-charon', 'charon', d)} \
27 ${@bb.utils.contains('DISTRO_FEATURES', 'tpm2', 'tpm2', '', d)} \
28 ${@bb.utils.contains('DISTRO_FEATURES', 'ima', 'tnc-imc imc-hcd imc-os imc-scanner imc-attestation', '', d)} \
29 ${@bb.utils.contains('DISTRO_FEATURES', 'ima', 'tnc-imv imv-hcd imv-os imv-scanner imv-attestation', '', d)} \
30"
31
32PACKAGECONFIG[aesni] = "--enable-aesni,--disable-aesni,,${PN}-plugin-aesni"
33PACKAGECONFIG[bfd] = "--enable-bfd-backtraces,--disable-bfd-backtraces,binutils"
34PACKAGECONFIG[charon] = "--enable-charon,--disable-charon,"
35PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl,${PN}-plugin-curl"
36PACKAGECONFIG[eap-identity] = "--enable-eap-identity,--disable-eap-identity,,${PN}-plugin-eap-identity"
37PACKAGECONFIG[eap-mschapv2] = "--enable-eap-mschapv2,--disable-eap-mschapv2,,${PN}-plugin-eap-mschapv2"
38PACKAGECONFIG[gmp] = "--enable-gmp,--disable-gmp,gmp,${PN}-plugin-gmp"
39PACKAGECONFIG[ldap] = "--enable-ldap,--disable-ldap,openldap,${PN}-plugin-ldap"
40PACKAGECONFIG[mysql] = "--enable-mysql,--disable-mysql,mysql5,${PN}-plugin-mysql"
41PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl,${PN}-plugin-openssl"
Patrick Williams92b42cb2022-09-03 06:53:57 -050042PACKAGECONFIG[soup] = "--enable-soup,--disable-soup,libsoup-2.4,${PN}-plugin-soup"
43PACKAGECONFIG[sqlite3] = "--enable-sqlite,--disable-sqlite,sqlite3,${PN}-plugin-sqlite"
44PACKAGECONFIG[stroke] = "--enable-stroke,--disable-stroke,,${PN}-plugin-stroke"
45PACKAGECONFIG[swanctl] = "--enable-swanctl,--disable-swanctl,,libgcc"
46PACKAGECONFIG[curve25519] = "--enable-curve25519,--disable-curve25519,, ${PN}-plugin-curve25519"
47
48# requires swanctl
49PACKAGECONFIG[systemd-charon] = "--enable-systemd,--disable-systemd,systemd,"
50
51# tpm needs meta-tpm layer
52PACKAGECONFIG[tpm2] = "--enable-tpm,--disable-tpm,,${PN}-plugin-tpm"
53
54
55# integraty configuration needs meta-integraty
56#imc
57PACKAGECONFIG[tnc-imc] = "--enable-tnc-imc,--disable-tnc-imc,, ${PN}-plugin-tnc-imc ${PN}-plugin-tnc-tnccs"
58PACKAGECONFIG[imc-test] = "--enable-imc-test,--disable-imc-test,,"
59PACKAGECONFIG[imc-scanner] = "--enable-imc-scanner,--disable-imc-scanner,,"
60PACKAGECONFIG[imc-os] = "--enable-imc-os,--disable-imc-os,,"
61PACKAGECONFIG[imc-attestation] = "--enable-imc-attestation,--disable-imc-attestation,,"
62PACKAGECONFIG[imc-swima] = "--enable-imc-swima, --disable-imc-swima, json-c,"
63PACKAGECONFIG[imc-hcd] = "--enable-imc-hcd, --disable-imc-hcd,,"
64
65#imv set
66PACKAGECONFIG[tnc-imv] = "--enable-tnc-imv,--disable-tnc-imv,, ${PN}-plugin-tnc-imv ${PN}-plugin-tnc-tnccs"
67PACKAGECONFIG[imv-test] = "--enable-imv-test,--disable-imv-test,,"
68PACKAGECONFIG[imv-scanner] = "--enable-imv-scanner,--disable-imv-scanner,,"
69PACKAGECONFIG[imv-os] = "--enable-imv-os,--disable-imv-os,,"
70PACKAGECONFIG[imv-attestation] = "--enable-imv-attestation,--disable-imv-attestation,,"
71PACKAGECONFIG[imv-swima] = "--enable-imv-swima, --disable-imv-swima, json-c,"
72PACKAGECONFIG[imv-hcd] = "--enable-imv-hcd, --disable-imv-hcd,,"
73
74PACKAGECONFIG[tnc-ifmap] = "--enable-tnc-ifmap,--disable-tnc-ifmap, libxml2, ${PN}-plugin-tnc-ifmap"
75PACKAGECONFIG[tnc-pdp] = "--enable-tnc-pdp,--disable-tnc-pdp,, ${PN}-plugin-tnc-pdp"
76
77PACKAGECONFIG[tnccs-11] = "--enable-tnccs-11,--disable-tnccs-11,libxml2, ${PN}-plugin-tnccs-11"
78PACKAGECONFIG[tnccs-20] = "--enable-tnccs-20,--disable-tnccs-20,, ${PN}-plugin-tnccs-20"
79PACKAGECONFIG[tnccs-dynamic] = "--enable-tnccs-dynamic,--disable-tnccs-dynamic,,${PN}-plugin-tnccs-dynamic"
80
81inherit autotools systemd pkgconfig
82
83RRECOMMENDS:${PN} = "kernel-module-ah4 \
84 kernel-module-esp4 \
85 kernel-module-xfrm-user \
86 "
87
88FILES:${PN} += "${libdir}/ipsec/lib*${SOLIBS}"
89FILES:${PN}-dbg += "${bindir}/.debug ${sbindir}/.debug ${libdir}/ipsec/.debug ${libexecdir}/ipsec/.debug"
90FILES:${PN}-dev += "${libdir}/ipsec/lib*${SOLIBSDEV} ${libdir}/ipsec/*.la ${libdir}/ipsec/include/config.h"
91FILES:${PN}-staticdev += "${libdir}/ipsec/*.a"
92
93CONFFILES:${PN} = "${sysconfdir}/*.conf ${sysconfdir}/ipsec.d/*.conf ${sysconfdir}/strongswan.d/*.conf"
94
95PACKAGES += "${PN}-plugins"
96ALLOW_EMPTY:${PN}-plugins = "1"
97
98PACKAGE_BEFORE_PN = "${PN}-imcvs ${PN}-imcvs-dbg"
99ALLOW_EMPTY:${PN}-imcvs = "1"
100
101FILES:${PN}-imcvs = "${libdir}/ipsec/imcvs/*.so"
102FILES:${PN}-imcvs-dbg += "${libdir}/ipsec/imcvs/.debug"
103
104PACKAGES_DYNAMIC += "^${PN}-plugin-.*$"
105NOAUTOPACKAGEDEBUG = "1"
106
107python split_strongswan_plugins () {
108 sysconfdir = d.expand('${sysconfdir}/strongswan.d/charon')
109 libdir = d.expand('${libdir}/ipsec/plugins')
110 dbglibdir = os.path.join(libdir, '.debug')
111
112 def add_plugin_conf(f, pkg, file_regex, output_pattern, modulename):
113 dvar = d.getVar('PKGD')
114 oldfiles = d.getVar('CONFFILES:' + pkg)
115 newfile = '/' + os.path.relpath(f, dvar)
116
117 if not oldfiles:
118 d.setVar('CONFFILES:' + pkg, newfile)
119 else:
120 d.setVar('CONFFILES:' + pkg, oldfiles + " " + newfile)
121
122 split_packages = do_split_packages(d, libdir, r'libstrongswan-(.*)\.so', '${PN}-plugin-%s', 'strongSwan %s plugin', prepend=True)
123 do_split_packages(d, sysconfdir, r'(.*)\.conf', '${PN}-plugin-%s', 'strongSwan %s plugin', prepend=True, hook=add_plugin_conf)
124
125 split_dbg_packages = do_split_packages(d, dbglibdir, r'libstrongswan-(.*)\.so', '${PN}-plugin-%s-dbg', 'strongSwan %s plugin - Debugging files', prepend=True, extra_depends='${PN}-dbg')
126 split_dev_packages = do_split_packages(d, libdir, r'libstrongswan-(.*)\.la', '${PN}-plugin-%s-dev', 'strongSwan %s plugin - Development files', prepend=True, extra_depends='${PN}-dev')
127 split_staticdev_packages = do_split_packages(d, libdir, r'libstrongswan-(.*)\.a', '${PN}-plugin-%s-staticdev', 'strongSwan %s plugin - Development files (Static Libraries)', prepend=True, extra_depends='${PN}-staticdev')
128
129 if split_packages:
130 pn = d.getVar('PN')
131 d.setVar('RRECOMMENDS:' + pn + '-plugins', ' '.join(split_packages))
132 d.appendVar('RRECOMMENDS:' + pn + '-dbg', ' ' + ' '.join(split_dbg_packages))
133 d.appendVar('RRECOMMENDS:' + pn + '-dev', ' ' + ' '.join(split_dev_packages))
134 d.appendVar('RRECOMMENDS:' + pn + '-staticdev', ' ' + ' '.join(split_staticdev_packages))
135}
136
137PACKAGESPLITFUNCS:prepend = "split_strongswan_plugins "
138
139# Install some default plugins based on default strongSwan ./configure options
140# See https://wiki.strongswan.org/projects/strongswan/wiki/Pluginlist
141RDEPENDS:${PN} += "\
142 ${PN}-plugin-aes \
143 ${PN}-plugin-attr \
144 ${PN}-plugin-cmac \
145 ${PN}-plugin-constraints \
146 ${PN}-plugin-des \
147 ${PN}-plugin-dnskey \
148 ${PN}-plugin-drbg \
149 ${PN}-plugin-fips-prf \
Patrick Williams2194f502022-10-16 14:26:09 -0500150 ${PN}-plugin-gcm \
Patrick Williams92b42cb2022-09-03 06:53:57 -0500151 ${PN}-plugin-hmac \
152 ${PN}-plugin-kdf \
153 ${PN}-plugin-kernel-netlink \
154 ${PN}-plugin-md5 \
155 ${PN}-plugin-mgf1 \
156 ${PN}-plugin-nonce \
157 ${PN}-plugin-pem \
158 ${PN}-plugin-pgp \
159 ${PN}-plugin-pkcs1 \
160 ${PN}-plugin-pkcs7 \
161 ${PN}-plugin-pkcs8 \
162 ${PN}-plugin-pkcs12 \
163 ${PN}-plugin-pubkey \
164 ${PN}-plugin-random \
165 ${PN}-plugin-rc2 \
166 ${PN}-plugin-resolve \
167 ${PN}-plugin-revocation \
168 ${PN}-plugin-sha1 \
169 ${PN}-plugin-sha2 \
170 ${PN}-plugin-socket-default \
171 ${PN}-plugin-sshkey \
172 ${PN}-plugin-updown \
173 ${PN}-plugin-vici \
174 ${PN}-plugin-x509 \
175 ${PN}-plugin-xauth-generic \
176 ${PN}-plugin-xcbc \
177 "
178
179RPROVIDES:${PN} += "${PN}-systemd"
180RREPLACES:${PN} += "${PN}-systemd"
181RCONFLICTS:${PN} += "${PN}-systemd"
182
183# The deprecated legacy 'strongswan-starter' service should only be used when charon and
184# stroke are enabled. When swanctl is in use, 'strongswan.service' is needed.
185# See: https://wiki.strongswan.org/projects/strongswan/wiki/Charon-systemd
186SYSTEMD_SERVICE:${PN} = " \
187 ${@bb.utils.contains('PACKAGECONFIG', 'swanctl', '${BPN}.service', '', d)} \
188 ${@bb.utils.contains('PACKAGECONFIG', 'charon', '${BPN}-starter.service', '', d)} \
189"