blob: aadf8b7f44f1e8a6761cb540b6c0652f712c7ed8 [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001SUMMARY = "Makes working with XML feel like you are working with JSON"
2AUTHOR = "Martin Blech"
3HOMEPAGE = "https://github.com/martinblech/xmltodict"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=01441d50dc74476db58a41ac10cb9fa2"
6
Patrick Williams2194f502022-10-16 14:26:09 -05007SRC_URI[sha256sum] = "341595a488e3e01a85a9d8911d8912fd922ede5fecc4dce437eb4b6c8d037e56"
Brad Bishope42b3e32020-01-15 22:08:42 -05008
9PYPI_PACKAGE = "xmltodict"
10
Andrew Geissler82c905d2020-04-13 13:39:40 -050011inherit pypi setuptools3 ptest
12
13SRC_URI += " \
14 file://run-ptest \
15"
16
Patrick Williams2194f502022-10-16 14:26:09 -050017RDEPENDS:${PN} += " \
18 ${PYTHON_PN}-core \
19 ${PYTHON_PN}-xml \
20 ${PYTHON_PN}-io \
21"
22
Patrick Williams213cb262021-08-07 19:21:33 -050023RDEPENDS:${PN}-ptest += " \
Andrew Geissler82c905d2020-04-13 13:39:40 -050024 ${PYTHON_PN}-pytest \
25"
26
27do_install_ptest() {
28 install -d ${D}${PTEST_PATH}/tests
29 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
30}