blob: d712a615a325223f684f9a86285486d1eb749ee8 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "Linux encrypted filesystem management tool"
2HOMEPAGE = "http://cryptmount.sourceforge.net/"
Patrick Williams2194f502022-10-16 14:26:09 -05003LIC_FILES_CHKSUM = "file://README;beginline=3;endline=4;md5=dae0772f0ff46fd927e7fdb08af51b71"
Patrick Williams92b42cb2022-09-03 06:53:57 -05004LICENSE = "GPL-2.0-only"
5
Patrick Williams2194f502022-10-16 14:26:09 -05006SRC_URI = "https://sourceforge.net/projects/cryptmount/files/${BPN}/${BPN}-${PV}/${BPN}-${PV}.tar.gz \
Patrick Williams92b42cb2022-09-03 06:53:57 -05007 "
8
Patrick Williams2194f502022-10-16 14:26:09 -05009SRC_URI[sha256sum] = "86528a9175e1eb53f60613e3c3ea6ae6d69dbfe5ac2b53b2f58ba0f768371e7e"
Patrick Williams92b42cb2022-09-03 06:53:57 -050010
11inherit autotools-brokensep gettext pkgconfig systemd
12
13EXTRA_OECONF = " --enable-cswap --enable-fsck --enable-argv0switch"
14
15PACKAGECONFIG ?="intl luks gcrypt nls"
16PACKAGECONFIG:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
17
18PACKAGECONFIG[systemd] = "--with-systemd, --without-systemd, systemd"
19PACKAGECONFIG[intl] = "--with-libintl-prefix, --without-libintl-prefix"
20PACKAGECONFIG[gcrypt] = "--with-libgcrypt, --without-libgcrypt, libgcrypt"
21PACKAGECONFIG[luks] = "--enable-luks, --disable-luks, cryptsetup"
22PACKAGECONFIG[nls] = "--enable-nls, --disable-nls, "
23
Andrew Geissler87f5cff2022-09-30 13:13:31 -050024SYSTEMD_PACKAGES = "${PN}"
Patrick Williams92b42cb2022-09-03 06:53:57 -050025SYSTEMD_SERVICE:${PN} = "cryptmount.service"
26
Andrew Geissler87f5cff2022-09-30 13:13:31 -050027do_install:append () {
28 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
29 install -D -m 0644 ${S}/sysinit/cryptmount.service ${D}${systemd_system_unitdir}/cryptmount.service
30 rm -fr ${D}/usr/lib
31 fi
32}
33
34FILES:${PN} += "${systemd_system_unitdir}"
35
Patrick Williams92b42cb2022-09-03 06:53:57 -050036RDEPENDS:${PN} = "libdevmapper"