blob: 53a02dc4bc8a946a1fa1bab149646a122c3027f7 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Run-time type checker for Python"
2HOMEPAGE = "https://pypi.org/project/typeguard/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=f0e423eea5c91e7aa21bdb70184b3e53"
5
Andrew Geissler220dafd2023-10-04 10:18:08 -05006SRC_URI[sha256sum] = "ea0a113bbc111bcffc90789ebb215625c963411f7096a7e9062d4e4630c155fd"
Andrew Geissler595f6302022-01-24 19:11:47 +00007
Andrew Geissler9aee5002022-03-30 16:27:02 +00008inherit pypi python_setuptools_build_meta ptest
Andrew Geissler595f6302022-01-24 19:11:47 +00009
10SRC_URI += " \
11 file://run-ptest \
12"
13
Patrick Williamsb542dec2023-06-09 01:26:37 -050014RDEPENDS:${PN} += " \
15 python3-compression \
16 python3-unittest \
17"
18
Andrew Geissler595f6302022-01-24 19:11:47 +000019RDEPENDS:${PN}-ptest += " \
20 ${PYTHON_PN}-pytest \
21 ${PYTHON_PN}-typing-extensions \
22 ${PYTHON_PN}-unixadmin \
23"
24
25do_install_ptest() {
26 install -d ${D}${PTEST_PATH}/tests
27 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
28}
29
30DEPENDS += "\
31 python3-distutils-extra-native \
32 python3-setuptools-scm-native \
33"
34
35BBCLASSEXTEND = "native nativesdk"