blob: 6a3687cf7218d2d097792d3b5af144bc61fce5fc [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "A 802.1ab implementation (LLDP) to help you locate neighbors of all your equipments"
2SECTION = "net/misc"
3LICENSE = "ISC"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/ISC;md5=f3b90e78ea0cffb20bf5cca7947a896d"
5
6DEPENDS = "libbsd libevent"
7
8SRC_URI = "\
9 http://media.luffy.cx/files/${BPN}/${BPN}-${PV}.tar.gz \
10 file://lldpd.init.d \
11 file://lldpd.default \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050012 "
13
Patrick Williams2390b1b2022-11-03 13:47:49 -050014SRC_URI[sha256sum] = "f7fe3a130be98a19c491479ef60f36b8ee41a9e6bc4d7f2c41033f63956a3126"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050015
Patrick Williams2390b1b2022-11-03 13:47:49 -050016inherit autotools update-rc.d useradd systemd pkgconfig bash-completion github-releases
Brad Bishopd7bf8c12018-02-25 22:55:05 -050017
18USERADD_PACKAGES = "${PN}"
Patrick Williams213cb262021-08-07 19:21:33 -050019USERADD_PARAM:${PN} = "--system -g lldpd --shell /bin/false lldpd"
20GROUPADD_PARAM:${PN} = "--system lldpd"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050021
22EXTRA_OECONF += "--without-embedded-libevent \
23 --disable-oldies \
24 --with-privsep-user=lldpd \
25 --with-privsep-group=lldpd \
26 --with-systemdsystemunitdir=${systemd_system_unitdir} \
27 --without-sysusersdir \
28"
29
30PACKAGECONFIG ??= "cdp fdp edp sonmp lldpmed dot1 dot3"
31PACKAGECONFIG[xml] = "--with-xml,--without-xml,libxm2"
32PACKAGECONFIG[snmp] = "--with-snmp,--without-snmp,net-snmp"
33PACKAGECONFIG[readline] = "--with-readline,--without-readline,readline"
34PACKAGECONFIG[seccomp] = "--with-seccomp,--without-seccomp,libseccomp"
35PACKAGECONFIG[cdp] = "--enable-cdp,--disable-cdp"
36PACKAGECONFIG[fdp] = "--enable-fdp,--disable-fdp"
37PACKAGECONFIG[edp] = "--enable-edp,--disable-edp"
38PACKAGECONFIG[sonmp] = "--enable-sonmp,--disable-sonmp"
39PACKAGECONFIG[lldpmed] = "--enable-lldpmed,--disable-lldpmed"
40PACKAGECONFIG[dot1] = "--enable-dot1,--disable-dot1"
41PACKAGECONFIG[dot3] = "--enable-dot3,--disable-dot3"
42PACKAGECONFIG[custom] = "--enable-custom,--disable-custom"
43
44INITSCRIPT_NAME = "lldpd"
45INITSCRIPT_PARAMS = "defaults"
46
Patrick Williams213cb262021-08-07 19:21:33 -050047SYSTEMD_SERVICE:${PN} = "lldpd.service"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050048
Patrick Williams213cb262021-08-07 19:21:33 -050049do_install:append() {
Brad Bishopd7bf8c12018-02-25 22:55:05 -050050 install -Dm 0755 ${WORKDIR}/lldpd.init.d ${D}${sysconfdir}/init.d/lldpd
51 install -Dm 0644 ${WORKDIR}/lldpd.default ${D}${sysconfdir}/default/lldpd
52 # Make an empty configuration file
53 touch ${D}${sysconfdir}/lldpd.conf
54}
55
56PACKAGES =+ "${PN}-zsh-completion"
57
Patrick Williams213cb262021-08-07 19:21:33 -050058FILES:${PN} += "${libdir}/sysusers.d"
59RDEPENDS:${PN} += "os-release"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050060
Patrick Williams213cb262021-08-07 19:21:33 -050061FILES:${PN}-zsh-completion += "${datadir}/zsh/"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050062# FIXME: zsh is broken in meta-oe so this cannot be enabled for now
Patrick Williams0ca19cc2021-08-16 14:03:13 -050063#RDEPENDS:${PN}-zsh-completion += "zsh"