blob: 95a651dd0389bce62311c5ee2d29fd5daa1a8683 [file] [log] [blame]
Andrew Geissler87f5cff2022-09-30 13:13:31 -05001SUMMARY = "OpenGL Mathematics Library for C"
2DESCRIPTION = "Highly optimized 2D|3D math library, also known as OpenGL Mathematics (glm) for `C`. \
3cglm provides lot of utils to help math operations to be fast and quick to write. It is community \
4friendly, feel free to bring any issues, bugs you faced."
5HOMEPAGE = "https://github.com/recp/cglm"
6BUGTRACKER = "https://github.com/recp/cglm/issues"
7SECTION = "libs"
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=8dc95c4110ba741c43832734b51b7de7"
10
11SRC_URI = "git://github.com/recp/cglm;branch=master;protocol=https"
12# Tag v0.8.5
Patrick Williams2390b1b2022-11-03 13:47:49 -050013SRCREV = "8cfc98d2835a8cd1a9041f257c7ba0bfe4fbc1f3"
Andrew Geissler87f5cff2022-09-30 13:13:31 -050014
15S = "${WORKDIR}/git"
16
17PACKAGECONFIG[build_tests] = "-Dbuild_tests=true,-Dbuild_tests=false,"
18
19PACKAGECONFIG ?= ""
20
21inherit meson pkgconfig
22
23EXTRA_OEMESON += "--buildtype release"
24
25BBCLASSEXTEND = "native"