blob: 5f5c4958d9448ac00c99ce798b3c95c506f4a7d3 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "MIME::Types - Definition of MIME types"
2DESCRIPTION = "MIME types are used in MIME compliant lines, for instance \
3as part of e-mail and HTTP traffic, to indicate the type of content which \
4is transmitted. Sometimes real knowledge about a mime-type is need.\
5\n\
6This module maintains a set of MIME::Type objects, which each describe \
7one known mime type."
8HOMEPAGE = "http://search.cpan.org/~markov/MIME-Types-${PV}"
9SECTION = "libraries"
10
Patrick Williams92b42cb2022-09-03 06:53:57 -050011LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
Brad Bishop316dfdd2018-06-25 12:45:53 -040012LIC_FILES_CHKSUM = "file://META.yml;beginline=11;endline=11;md5=963ce28228347875ace682de56eef8e8"
13
14SRC_URI = "http://search.cpan.org/CPAN/authors/id/M/MA/MARKOV/MIME-Types-${PV}.tar.gz \
15 file://run-ptest \
16 "
Patrick Williams2390b1b2022-11-03 13:47:49 -050017SRC_URI[sha256sum] = "c2545eb30b094e942860ff8444f0f6cb54641caa8f7d386aaa2d925da4b02400"
Brad Bishop316dfdd2018-06-25 12:45:53 -040018
19S = "${WORKDIR}/MIME-Types-${PV}"
20
21inherit cpan ptest
22
Patrick Williams213cb262021-08-07 19:21:33 -050023RDEPENDS:${PN} = "\
Brad Bishop316dfdd2018-06-25 12:45:53 -040024 perl-module-base \
Patrick Williams2390b1b2022-11-03 13:47:49 -050025 perl-module-carp \
26 perl-module-constant \
27 perl-module-cwd \
28 perl-module-encode-encoding \
Brad Bishop316dfdd2018-06-25 12:45:53 -040029 perl-module-file-basename \
30 perl-module-file-spec \
Patrick Williams2390b1b2022-11-03 13:47:49 -050031 perl-module-list-util \
Brad Bishop316dfdd2018-06-25 12:45:53 -040032 perl-module-overload \
Patrick Williams2390b1b2022-11-03 13:47:49 -050033 perl-module-perlio \
34 perl-module-perlio-encoding \
Brad Bishop316dfdd2018-06-25 12:45:53 -040035"
36
Patrick Williams2390b1b2022-11-03 13:47:49 -050037RDEPENDS:${PN}-ptest = "\
38 perl-module-lib \
39 perl-module-test-more \
40"
Brad Bishop316dfdd2018-06-25 12:45:53 -040041
Patrick Williams2390b1b2022-11-03 13:47:49 -050042#RSUGGESTS:${PN}-ptest = "libmojo-base-perl"
Brad Bishop316dfdd2018-06-25 12:45:53 -040043
44do_install_ptest () {
45 cp -r ${B}/t ${D}${PTEST_PATH}
46}