blob: dbedd4913be4ad16940902c212670407ddf8f2c7 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001DESCRIPTION = "Google gRPC tools"
2HOMEPAGE = "http://www.grpc.io/"
3SECTION = "devel/python"
4
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=7145f7cdd263359b62d342a02f005515"
7
8inherit pypi setuptools3
9
10DEPENDS += "${PYTHON_PN}-grpcio"
11
Andrew Geissler87f5cff2022-09-30 13:13:31 -050012SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch \
13 file://0001-protobuf-Disable-musttail-attribute-on-mips.patch \
14 "
Patrick Williams2390b1b2022-11-03 13:47:49 -050015SRC_URI[sha256sum] = "88b75f2afd889c7c6939f58d76b58ab84de4723c7de882a1f8448af6632e256f"
Patrick Williams92b42cb2022-09-03 06:53:57 -050016
17RDEPENDS:${PN} = "${PYTHON_PN}-grpcio"
18
19BBCLASSEXTEND = "native nativesdk"