blob: 566279d71c519077f9dc16741b9bf44df5bf0d44 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "A generic, spec-compliant, thorough implementation of the OAuth request-signing logic"
2HOMEPAGE = "https://github.com/idan/oauthlib"
3
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=abd2675e944a2011aed7e505290ba482"
6
Patrick Williams2390b1b2022-11-03 13:47:49 -05007SRC_URI[sha256sum] = "9859c40929662bec5d64f34d01c99e093149682a3f38915dc0655d5a633dd918"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00008
9inherit pypi setuptools3
10
11# The following configs & dependencies are from setuptools extras_require.
12# These dependencies are optional, hence can be controlled via PACKAGECONFIG.
13# The upstream names may not correspond exactly to bitbake package names.
14#
15# Uncomment this line to enable all the optional features.
16#PACKAGECONFIG ?= "test signedtoken signals rsa"
17PACKAGECONFIG[test] = ",,,${PYTHON_PN}-blinker ${PYTHON_PN}-cryptography ${PYTHON_PN}-pytest ${PYTHON_PN}-pyjwt"
18PACKAGECONFIG[signedtoken] = ",,,${PYTHON_PN}-cryptography ${PYTHON_PN}-pyjwt"
19PACKAGECONFIG[signals] = ",,,${PYTHON_PN}-blinker"
20PACKAGECONFIG[rsa] = ",,,${PYTHON_PN}-cryptography"
21
22RDEPENDS:${PN} += "${PYTHON_PN}-core ${PYTHON_PN}-crypt ${PYTHON_PN}-datetime ${PYTHON_PN}-json ${PYTHON_PN}-logging ${PYTHON_PN}-math ${PYTHON_PN}-netclient ${PYTHON_PN}-unittest"