blob: 0f620096a858f92b6ae80ed8a75cf59e041b1d54 [file] [log] [blame]
Andrew Geisslerf1e44062021-04-15 15:52:46 -05001SUMMARY = "Parsec Command Line Interface"
2HOMEPAGE = "https://github.com/parallaxsecond/parsec-tool"
3LICENSE = "Apache-2.0"
4
5inherit cargo
6
7SRC_URI += "crate://crates.io/parsec-tool/${PV} \
8"
9
Patrick Williams93c203f2021-10-06 16:15:23 -050010RDEPENDS:${PN} = "openssl-bin"
11
Andrew Geisslerf1e44062021-04-15 15:52:46 -050012do_install() {
13 install -d ${D}/${bindir}
Patrick Williams92b42cb2022-09-03 06:53:57 -050014 install -m 755 "${B}/target/${CARGO_TARGET_SUBDIR}/parsec-tool" "${D}${bindir}/parsec-tool"
Patrick Williams93c203f2021-10-06 16:15:23 -050015 install -m 755 "${S}/tests/parsec-cli-tests.sh" "${D}${bindir}/parsec-cli-tests.sh"
Andrew Geisslerf1e44062021-04-15 15:52:46 -050016}
17
18require parsec-tool_${PV}.inc
Patrick Williams2390b1b2022-11-03 13:47:49 -050019
20# The QA check has been temporarily disabled. An issue has been created
21# upstream to fix this.
22# https://github.com/parallaxsecond/parsec-tool/issues/94
23INSANE_SKIP:${PN}-dbg += "buildpaths"