blob: b6768719cba09a7abcdbd8448fcd3c8cc707cbf8 [file] [log] [blame]
Patrick Williams03907ee2022-05-01 06:28:52 -05001SUMMARY = "Provider for integration of TPM 2.0 to OpenSSL 3.0"
2LICENSE = "BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=b75785ac083d3c3ca04d99d9e4e1fbab"
4
5DEPENDS = "autoconf-archive-native tpm2-tss openssl"
6
7SRC_URI = "https://github.com/tpm2-software/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.gz"
8
Patrick Williams2390b1b2022-11-03 13:47:49 -05009SRC_URI[sha256sum] = "5a9bb0c6c61d026272b8843cbc291b5dfa9a55c1661a513b1c980807ad2dad01"
Patrick Williams03907ee2022-05-01 06:28:52 -050010
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050011UPSTREAM_CHECK_URI = "https://github.com/tpm2-software/${BPN}/releases"
12
Patrick Williams03907ee2022-05-01 06:28:52 -050013inherit autotools pkgconfig
14
15do_configure:prepend() {
16 # do not extract the version number from git
17 sed -i -e 's/m4_esyscmd_s(\[git describe --tags --always --dirty\])/${PV}/' ${S}/configure.ac
18}
19
20FILES:${PN} = "\
21 ${libdir}/ossl-modules/tpm2.so"