blob: 1fc23acb74c24a6dc4d65e5fd9f113a2a7df8c8f [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "helper tools for all init systems"
2DESCRIPTION = "This package contains helper tools that are necessary for switching between \
3the various init systems that Debian contains (e. g. sysvinit or \
4systemd). An example is deb-systemd-helper, a script that enables systemd unit \
5files without depending on a running systemd. \
6\
7It also includes the \"service\", \"invoke-rc.d\", and \"update-rc.d\" scripts which \
8provide an abstraction for enabling, disabling, starting, and stopping \
9services for all supported Debian init systems as specified by the policy. \
10\
11While this package is maintained by pkg-systemd-maintainers, it is NOT \
12specific to systemd at all. Maintainers of other init systems are welcome to \
13include their helpers in this package."
14HOMEPAGE = "https://salsa.debian.org/debian/init-system-helpers"
15SECTION = "base"
16LICENSE = "BSD-3-Clause & GPL-2.0-only"
Andrew Geissler615f2f12022-07-15 14:00:58 -050017LIC_FILES_CHKSUM = "file://debian/copyright;md5=c4ec20aa158fa9de26ee1accf78dcaae"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000018
Patrick Williams2390b1b2022-11-03 13:47:49 -050019SRCREV = "2f446b69db728b2bda68270a9b81de88102e1fdd"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000020SRC_URI = "git://salsa.debian.org/debian/init-system-helpers.git;protocol=https;branch=master"
Andrew Geissler87f5cff2022-09-30 13:13:31 -050021UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))(?!_exp)"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000022
23S = "${WORKDIR}/git"
24
25do_configure[noexec] = "1"
26do_compile[noexec] = "1"
27
28do_install() {
29 install -d -m 0755 ${D}${sbindir}
30 install -m 0755 ${S}/script/invoke-rc.d ${D}${sbindir}
31 install -m 0755 ${S}/script/service ${D}${sbindir}
32}
33
34PACKAGES += "${PN}-invoke-rc.d ${PN}-service"
35
36FILES:${PN} = ""
37FILES:${PN}-invoke-rc.d = "${sbindir}/invoke-rc.d"
38FILES:${PN}-service = "${sbindir}/service"
39
40ALLOW_EMPTY:${PN} = "1"
41
42RRECOMMENDS:${PN} += "${PN}-invoke-rc.d ${PN}-service"