blob: 6ce45ca6ee117e07edb1ccd2e7047e9f0fd5686a [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001DESCRIPTION = "Modern password hashing for your software and your servers."
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=8f7bb094c7232b058c7e9f2e431f389c"
4HOMEPAGE = "https://pypi.org/project/bcrypt/"
5
6DEPENDS += "${PYTHON_PN}-cffi-native"
7
Patrick Williams2390b1b2022-11-03 13:47:49 -05008SRC_URI[sha256sum] = "27d375903ac8261cfe4047f6709d16f7d18d39b1ec92aaf72af989552a650ebd"
Andrew Geissler9aee5002022-03-30 16:27:02 +00009
Patrick Williams2390b1b2022-11-03 13:47:49 -050010inherit pypi python_setuptools3_rust ptest cargo-update-recipe-crates
Andrew Geissler9aee5002022-03-30 16:27:02 +000011
12SRC_URI += " \
13 file://run-ptest \
14"
15
Patrick Williams2390b1b2022-11-03 13:47:49 -050016require ${BPN}-crates.inc
17
Andrew Geissler9aee5002022-03-30 16:27:02 +000018RDEPENDS:${PN}-ptest += " \
19 ${PYTHON_PN}-pytest \
20"
21
22do_install_ptest() {
23 install -d ${D}${PTEST_PATH}/tests
24 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
25}
26
27RDEPENDS:${PN}:class-target += "\
28 ${PYTHON_PN}-cffi \
29 ${PYTHON_PN}-ctypes \
30 ${PYTHON_PN}-shell \
31 ${PYTHON_PN}-six \
32"