blob: 359560b9e24d4f021d615dc642428aee9c520762 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "System load testing utility"
2DESCRIPTION = "Deliberately simple workload generator for POSIX systems. It \
3imposes a configurable amount of CPU, memory, I/O, and disk stress on the system."
4HOMEPAGE = "https://github.com/ColinIanKing/stress-ng#readme"
5LICENSE = "GPL-2.0-only"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
Patrick Williams2390b1b2022-11-03 13:47:49 -05008SRC_URI = "git://github.com/ColinIanKing/stress-ng.git;protocol=https;branch=master"
9SRCREV = "03493cb69e91c29718ff9f645514355cd99762c6"
Patrick Williams92b42cb2022-09-03 06:53:57 -050010S = "${WORKDIR}/git"
11
12DEPENDS = "coreutils-native"
13
14PROVIDES = "stress"
15RPROVIDES:${PN} = "stress"
16RREPLACES:${PN} = "stress"
17RCONFLICTS:${PN} = "stress"
18
19inherit bash-completion
20
21do_compile:prepend() {
22 mkdir -p configs
23 touch configs/HAVE_APPARMOR
24}
25
26do_install() {
27 oe_runmake DESTDIR=${D} install
28 ln -s stress-ng ${D}${bindir}/stress
29}