blob: d0b3458e1bb76328de2511fffd2b09bf55dc46f0 [file] [log] [blame]
Andrew Geissler6ce62a22020-11-30 19:58:47 -06001DESCRIPTION = "The Vulkan Samples is collection of resources to help develop optimized Vulkan applications."
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002HOMEPAGE = "https://www.khronos.org/vulkan/"
3BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-Samples/issues"
Andrew Geissler6ce62a22020-11-30 19:58:47 -06004LICENSE = "Apache-2.0"
5
6LIC_FILES_CHKSUM = "file://LICENSE;md5=48aa35cefb768436223a6e7f18dc2a2a"
7
Patrick Williams2390b1b2022-11-03 13:47:49 -05008SRC_URI = "gitsm://github.com/KhronosGroup/Vulkan-Samples.git;branch=master;protocol=https;lfs=0 \
Andrew Geissler6ce62a22020-11-30 19:58:47 -06009 file://0001-CMakeLists.txt-do-not-hardcode-lib-as-installation-t.patch \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060010 file://debugfix.patch \
Patrick Williams92b42cb2022-09-03 06:53:57 -050011 file://0001-Qualify-move-as-std-move.patch;patchdir=third_party/spirv-cross \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060012 "
13
14UPSTREAM_CHECK_COMMITS = "1"
Patrick Williams92b42cb2022-09-03 06:53:57 -050015SRCREV = "74d45aace02d99d766126711a8aaa0978276ca00"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060016
17UPSTREAM_CHECK_GITTAGREGEX = "These are not the releases you're looking for"
18S = "${WORKDIR}/git"
19
20REQUIRED_DISTRO_FEATURES = 'vulkan'
Andrew Geissler595f6302022-01-24 19:11:47 +000021COMPATIBLE_HOST = "(x86_64|aarch64|mips64|powerpc64|riscv64).*-linux"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060022
23inherit cmake features_check
24
Patrick Williams213cb262021-08-07 19:21:33 -050025FILES:${PN} += "${datadir}"
Andrew Geisslerd1e89492021-02-12 15:35:20 -060026
27#
28# There is code to remove the prefix CMAKE_SOURCE_DIR from __FILENAME__ paths
29# used for logging with LOGE in the code. We need to make this match the value we use
30# in the debug source remapping from CFLAGS
31#
32EXTRA_OECMAKE += "-DCMAKE_DEBUG_SRCDIR=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/"
33# Binaries built with PCH enabled don't appear reproducible, differing results were seen
34# from some builds depending on the point the PCH was compiled. Disable it to be
35# deterministic
36EXTRA_OECMAKE += "-DCMAKE_DISABLE_PRECOMPILE_HEADERS=ON"
Patrick Williams213cb262021-08-07 19:21:33 -050037
38# This needs to be specified explicitly to avoid xcb/xlib dependencies
39EXTRA_OECMAKE += "-DVKB_WSI_SELECTION=D2D"