blob: aeb04f59e8d27f5639aa42694c0632a06a78d31f [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# This recipe tracks the linux-yocto-dev repository as its upstream source.
2# Since this tree is frequently updated, and periodically rebuilt, AUTOREV is
3# used to track its contents.
4#
5# This recipe is just like other linux-yocto variants, with the only difference
6# being that to avoid network access during initial parsing, static SRCREVs are
7# provided and overridden if the preferred kernel provider is linux-yocto-dev.
8#
9# To enable this recipe, set PREFERRED_PROVIDER_virtual/kernel = "linux-yocto-dev"
10
11inherit kernel
12require recipes-kernel/linux/linux-yocto.inc
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013# for ncurses tests
14inherit pkgconfig
Patrick Williamsc124f4f2015-09-15 14:41:29 -050015
16# provide this .inc to set specific revisions
17include recipes-kernel/linux/linux-yocto-dev-revisions.inc
18
Andrew Geissler615f2f12022-07-15 14:00:58 -050019KBRANCH = "v5.19/standard/base"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050020KMETA = "kernel-meta"
21
22SRC_URI = "git://git.yoctoproject.org/linux-yocto-dev.git;branch=${KBRANCH};name=machine \
23 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=master;destsuffix=${KMETA}"
24
25# Set default SRCREVs. Both the machine and meta SRCREVs are statically set
26# to the korg v3.7 tag, and hence prevent network access during parsing. If
27# linux-yocto-dev is the preferred provider, they will be overridden to
28# AUTOREV in following anonymous python routine and resolved when the
29# variables are finalized.
30SRCREV_machine ?= '${@oe.utils.conditional("PREFERRED_PROVIDER_virtual/kernel", "linux-yocto-dev", "${AUTOREV}", "29594404d7fe73cd80eaa4ee8c43dcc53970c60e", d)}'
31SRCREV_meta ?= '${@oe.utils.conditional("PREFERRED_PROVIDER_virtual/kernel", "linux-yocto-dev", "${AUTOREV}", "29594404d7fe73cd80eaa4ee8c43dcc53970c60e", d)}'
32
Andrew Geissler615f2f12022-07-15 14:00:58 -050033LINUX_VERSION ?= "5.19+"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050034LINUX_VERSION_EXTENSION ?= "-yoctodev-${LINUX_KERNEL_TYPE}"
35PV = "${LINUX_VERSION}+git${SRCPV}"
36
Andrew Geissler82c905d2020-04-13 13:39:40 -050037LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080038
Brad Bishop316dfdd2018-06-25 12:45:53 -040039DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
40DEPENDS += "openssl-native util-linux-native"
Andrew Geisslereff27472021-10-29 15:35:00 -050041DEPENDS += "gmp-native libmpc-native"
Brad Bishop316dfdd2018-06-25 12:45:53 -040042
Andrew Geissler595f6302022-01-24 19:11:47 +000043# yaml and dtschema are required for 5.16+ device tree validation, libyaml is checked
44# via pkgconfig, so must always be present, but we can wrap the others to make them
45# conditional
46DEPENDS += "libyaml-native"
47
48PACKAGECONFIG ??= ""
49PACKAGECONFIG[dt-validation] = ",,python3-dtschema-native"
50# we need the wrappers if validation isn't in the packageconfig
51DEPENDS += "${@bb.utils.contains('PACKAGECONFIG', 'dt-validation', '', 'python3-dtschema-wrapper-native', d)}"
52
Patrick Williams2390b1b2022-11-03 13:47:49 -050053COMPATIBLE_MACHINE = "^(qemuarmv5|qemuarm|qemuarm64|qemux86|qemuppc|qemumips|qemumips64|qemux86-64|qemuriscv32|qemuriscv64)$"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050054
Patrick Williams213cb262021-08-07 19:21:33 -050055KERNEL_DEVICETREE:qemuarmv5 = "versatile-pb.dtb"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060056
Patrick Williamsc124f4f2015-09-15 14:41:29 -050057# Functionality flags
58KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/taskstats/taskstats.scc"
Patrick Williams213cb262021-08-07 19:21:33 -050059KERNEL_FEATURES:append = " ${KERNEL_EXTRA_FEATURES}"
60KERNEL_FEATURES:append:qemuall=" cfg/virtio.scc features/drm-bochs/drm-bochs.scc"
61KERNEL_FEATURES:append:qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
62KERNEL_FEATURES:append:qemux86-64=" cfg/sound.scc cfg/paravirt_kvm.scc"
63KERNEL_FEATURES:append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "", d)}"
64KERNEL_FEATURES:append = " ${@bb.utils.contains("DISTRO_FEATURES", "ptest", " features/scsi/scsi-debug.scc", "", d)}"
65KERNEL_FEATURES:append = " ${@bb.utils.contains("DISTRO_FEATURES", "ptest", " features/gpio/mockup.scc", "", d)}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050066
Brad Bishop6e60e8b2018-02-01 10:27:11 -050067KERNEL_VERSION_SANITY_SKIP = "1"