blob: 361bb0f8dc927d9128ec4434ca56a798174c3ec5 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "GNOME XSLT library"
2DESCRIPTION = "libxslt is the XSLT C parser and toolkit developed for the Gnome project. \
3XSLT itself is a an XML language to define transformation for XML. Libxslt is based on \
4libxml2 the XML C library developed for the GNOME project. It also implements most of \
5the EXSLT set of processor-portable extensions functions and some of Saxon's evaluate \
6and expressions extensions."
7HOMEPAGE = "http://xmlsoft.org/XSLT/"
8BUGTRACKER = "https://bugzilla.gnome.org/"
9
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://Copyright;md5=0cd9a07afbeb24026c9b03aecfeba458"
12
13SECTION = "libs"
14DEPENDS = "libxml2"
15
16SRC_URI = "https://download.gnome.org/sources/libxslt/1.1/libxslt-${PV}.tar.xz"
17
Patrick Williams2390b1b2022-11-03 13:47:49 -050018SRC_URI[sha256sum] = "3a4b27dc8027ccd6146725950336f1ec520928f320f144eb5fa7990ae6123ab4"
Andrew Geissler9aee5002022-03-30 16:27:02 +000019
20UPSTREAM_CHECK_REGEX = "libxslt-(?P<pver>\d+(\.\d+)+)\.tar"
21
Andrew Geissler78b72792022-06-14 06:47:25 -050022# We have libxml2 2.9.14 and we don't link statically with it anyway
23# so this isn't an issue.
24CVE_CHECK_IGNORE += "CVE-2022-29824"
25
Andrew Geissler9aee5002022-03-30 16:27:02 +000026S = "${WORKDIR}/libxslt-${PV}"
27
28BINCONFIG = "${bindir}/xslt-config"
29
30inherit autotools pkgconfig binconfig-disabled lib_package multilib_header
31
32do_configure:prepend () {
33 # We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header.
34 # This can be removed when upgrading to 1.1.34.
35 sed -i -e 's/ansidecl.h//' ${S}/configure.ac
36
37 # The timestamps in the 1.1.28 tarball are messed up causing this file to
38 # appear out of date. Touch it so that we don't try to regenerate it.
39 touch ${S}/doc/xsltproc.1
40}
41
Patrick Williams2390b1b2022-11-03 13:47:49 -050042EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
Andrew Geissler9aee5002022-03-30 16:27:02 +000043# older versions of this recipe had ${PN}-utils
44RPROVIDES:${PN}-bin += "${PN}-utils"
45RCONFLICTS:${PN}-bin += "${PN}-utils"
46RREPLACES:${PN}-bin += "${PN}-utils"
47
48# This is only needed until libxml can load the relocated catalog itself
49do_install:append:class-native () {
50 create_wrapper ${D}/${bindir}/xsltproc XML_CATALOG_FILES=${sysconfdir}/xml/catalog
51}
52
53do_install:append () {
54 oe_multilib_header libxslt/xsltconfig.h
55}
56
57FILES:${PN} += "${libdir}/libxslt-plugins"
58FILES:${PN}-dev += "${libdir}/xsltConf.sh"
59
60BBCLASSEXTEND = "native nativesdk"