blob: 7daf80f36eba98a4a5898a6d805d611caa88868f [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "Collection of simple PIN or passphrase entry dialogs"
2DESCRIPTION = "\
3 Pinentry is a collection of simple PIN or passphrase entry dialogs which \
4 utilize the Assuan protocol as described by the aegypten project; see \
5 http://www.gnupg.org/aegypten/ for details."
6
7HOMEPAGE = "http://www.gnupg.org/related_software/pinentry/index.en.html"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00008LICENSE = "GPL-2.0-only"
Andrew Geisslereff27472021-10-29 15:35:00 -05009LIC_FILES_CHKSUM = "file://COPYING;md5=cbbd794e2a0a289b9dfcc9f513d1996e"
10
11DEPENDS = "gettext-native libassuan libgpg-error"
12
13UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
14SRC_URI = "${GNUPG_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
15 file://libassuan_pkgconf.patch \
16 file://gpg-error_pkconf.patch \
17"
18
Patrick Williams2390b1b2022-11-03 13:47:49 -050019SRC_URI[sha256sum] = "457a185e5a85238fb945a955dc6352ab962dc8b48720b62fc9fa48c7540a4067"
Andrew Geisslereff27472021-10-29 15:35:00 -050020
21inherit autotools pkgconfig
22
Patrick Williams2390b1b2022-11-03 13:47:49 -050023PACKAGECONFIG ??= "ncurses"
Andrew Geisslereff27472021-10-29 15:35:00 -050024
25PACKAGECONFIG[ncurses] = "--enable-ncurses --with-ncurses-include-dir=${STAGING_INCDIR}, --disable-ncurses, ncurses"
Andrew Geisslereff27472021-10-29 15:35:00 -050026PACKAGECONFIG[qt] = "--enable-pinentry-qt, --disable-pinentry-qt, qtbase-native qtbase"
27PACKAGECONFIG[gtk2] = "--enable-pinentry-gtk2, --disable-pinentry-gtk2, gtk+ glib-2.0"
28
29PACKAGECONFIG[secret] = "--enable-libsecret, --disable-libsecret, libsecret"
30
31EXTRA_OECONF = " \
32 --disable-rpath \
33"
Patrick Williams92b42cb2022-09-03 06:53:57 -050034EXTRA_OECONF:append:libc-musl = " \
35 ac_cv_should_define__xopen_source=yes \
36"
Andrew Geisslereff27472021-10-29 15:35:00 -050037
38BBCLASSEXTEND = "native nativesdk"