blob: aa438e58598c6fa969846cd54477abc607a64b8c [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Linux Kernel Crypto API User Space Interface Library"
2HOMEPAGE = "http://www.chronox.de/libkcapi.html"
3LICENSE = "BSD | GPL-2.0"
Brad Bishop19323692019-04-05 15:28:33 -04004LIC_FILES_CHKSUM = "file://COPYING;md5=14d5a68b28755c04ebdba226e888b157"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08005
6DEPENDS = "libtool"
7
8S = "${WORKDIR}/git"
Brad Bishop26bdd442019-08-16 17:08:17 -04009SRCREV = "5649050d201856bf06c8738b5d2aa1710c86ac2f"
10PV = "1.1.5"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011SRC_URI = " \
12 git://github.com/smuellerDD/libkcapi.git \
Brad Bishop23eaf032019-11-20 05:15:02 -050013 file://0001-kcapi-kdf-Move-code-to-fix.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014"
15
16inherit autotools
17
18PACKAGECONFIG ??= ""
Brad Bishop19323692019-04-05 15:28:33 -040019PACKAGECONFIG[testapp] = "--enable-kcapi-test,,,bash"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080020PACKAGECONFIG[apps] = "--enable-kcapi-speed --enable-kcapi-hasher --enable-kcapi-rngapp --enable-kcapi-encapp --enable-kcapi-dgstapp,,,"
21
22do_install_append() {
23 # bindir contains testapp and apps. However it is always created, even
24 # when no binaries are installed (empty bin_PROGRAMS in Makefile.am),
25 rmdir --ignore-fail-on-non-empty ${D}${bindir}
Brad Bishop19323692019-04-05 15:28:33 -040026
27 # Remove the generated binary checksum files
28 rm -f ${D}${bindir}/.*.hmac
29 rm -f ${D}${libdir}/.*.hmac
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080030}
31
32CPPFLAGS_append_libc-musl_toolchain-clang = " -Wno-error=sign-compare"