blob: 6c191fbde3530a9d569d85a28b7f13c06b09aef9 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "The tdb library"
2HOMEPAGE = "http://tdb.samba.org/"
3SECTION = "libs"
4LICENSE = "LGPL-3.0+ & GPL-3.0+"
5
6LIC_FILES_CHKSUM = "file://tools/tdbdump.c;endline=18;md5=b59cd45aa8624578126a8c98f48018c4 \
7 file://include/tdb.h;endline=27;md5=f5bb544641d3081821bcc1dd58310be6"
8
9SRC_URI = "https://samba.org/ftp/tdb/tdb-${PV}.tar.gz \
Brad Bishop19323692019-04-05 15:28:33 -040010 file://tdb-Add-configure-options-for-packages.patch \
11 file://0001-waf-add-support-of-cross_compile.patch \
Brad Bishop19323692019-04-05 15:28:33 -040012"
13
Brad Bishop26bdd442019-08-16 17:08:17 -040014SRC_URI[md5sum] = "c4c2f8cf9e691244a7f2ecfa3baadecc"
15SRC_URI[sha256sum] = "c1a0729c5400fb495465fa4bd953ae290db43c28dacd0506aef50dc482132d35"
Brad Bishop19323692019-04-05 15:28:33 -040016
17PACKAGECONFIG ??= "\
18 ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)} \
19 ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'attr', '', d)} \
20"
21
22PACKAGECONFIG[acl] = "--with-acl,--without-acl,acl"
23PACKAGECONFIG[attr] = "--with-attr,--without-attr,attr"
24PACKAGECONFIG[libaio] = "--with-libaio,--without-libaio,libaio"
25PACKAGECONFIG[libbsd] = "--with-libbsd,--without-libbsd,libbsd"
26PACKAGECONFIG[libcap] = "--with-libcap,--without-libcap,libcap"
27PACKAGECONFIG[valgrind] = "--with-valgrind,--without-valgrind,valgrind"
28
29S = "${WORKDIR}/tdb-${PV}"
30
31inherit waf-samba
32
33#cross_compile cannot use preforked process, since fork process earlier than point subproces.popen
34#to cross Popen
35export WAF_NO_PREFORK="yes"
36
37EXTRA_OECONF += "--disable-rpath \
38 --bundled-libraries=NONE \
39 --builtin-libraries=replace \
40 --with-libiconv=${STAGING_DIR_HOST}${prefix}\
41 "
42
Brad Bishop26bdd442019-08-16 17:08:17 -040043do_install_append() {
44 # add this link for cross check python module existence. eg: on x86-64 host, check python module
45 # under recipe-sysroot which is mips64.
46 cd ${D}${PYTHON_SITEPACKAGES_DIR}; ln -s tdb.*.so tdb.so
47}
Brad Bishop19323692019-04-05 15:28:33 -040048
Brad Bishop26bdd442019-08-16 17:08:17 -040049PACKAGES += "tdb-tools python3-tdb"
50
51RPROVIDES_${PN}-dbg += "python3-tdb-dbg"
Brad Bishop19323692019-04-05 15:28:33 -040052
53FILES_${PN} = "${libdir}/*.so.*"
54FILES_tdb-tools = "${bindir}/*"
Brad Bishop26bdd442019-08-16 17:08:17 -040055FILES_python3-tdb = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/*"
56RDEPENDS_python3-tdb = "python3"
57INSANE_SKIP_${MLPREFIX}python3-tdb = "dev-so"