blob: a581d3abfc34450cc326047f3cdf5a5eb1ef5ad5 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Hierarchical, reference counted memory pool system with destructors"
2HOMEPAGE = "http://tevent.samba.org"
3SECTION = "libs"
4LICENSE = "LGPLv3+"
5
6DEPENDS += "libtalloc libtirpc"
Brad Bishop26bdd442019-08-16 17:08:17 -04007RDEPENDS_python3-tevent = "python3"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08008
9SRC_URI = "https://samba.org/ftp/tevent/tevent-${PV}.tar.gz \
Brad Bishop26bdd442019-08-16 17:08:17 -040010 file://options-0.10.0.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011 file://0001-libtevent-fix-musl-libc-compile-error.patch \
Brad Bishop26bdd442019-08-16 17:08:17 -040012 file://0001-waf-add-support-of-cross_compile.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013"
14LIC_FILES_CHKSUM = "file://tevent.h;endline=26;md5=4e458d658cb25e21efc16f720e78b85a"
15
Brad Bishop26bdd442019-08-16 17:08:17 -040016SRC_URI[md5sum] = "97ea9861252e52c24adf6c45ab676a60"
17SRC_URI[sha256sum] = "33f39612cd6d1ae6a737245784581494846f5bb07827983d2f41f942446aa4e6"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080018
19inherit waf-samba
20
21PACKAGECONFIG ??= "\
22 ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)} \
23 ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'attr', '', d)} \
24"
25PACKAGECONFIG[acl] = "--with-acl,--without-acl,acl"
26PACKAGECONFIG[attr] = "--with-attr,--without-attr,attr"
27PACKAGECONFIG[libaio] = "--with-libaio,--without-libaio,libaio"
28PACKAGECONFIG[libbsd] = "--with-libbsd,--without-libbsd,libbsd"
29PACKAGECONFIG[libcap] = "--with-libcap,--without-libcap,libcap"
30PACKAGECONFIG[valgrind] = "--with-valgrind,--without-valgrind,valgrind"
31
32SRC_URI += "${@bb.utils.contains('PACKAGECONFIG', 'attr', '', 'file://avoid-attr-unless-wanted.patch', d)}"
33
34S = "${WORKDIR}/tevent-${PV}"
35
Brad Bishop26bdd442019-08-16 17:08:17 -040036#cross_compile cannot use preforked process, since fork process earlier than point subproces.popen
37#to cross Popen
38export WAF_NO_PREFORK="yes"
39
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080040EXTRA_OECONF += "--disable-rpath \
41 --bundled-libraries=NONE \
42 --builtin-libraries=replace \
43 --with-libiconv=${STAGING_DIR_HOST}${prefix}\
44 --without-gettext \
45 "
Brad Bishop26bdd442019-08-16 17:08:17 -040046do_install_append() {
47 # add this link for cross check python module existence. eg: on x86-64 host, check python module
48 # under recipe-sysroot which is mips64.
49 cd ${D}${PYTHON_SITEPACKAGES_DIR}; ln -s _tevent.*.so _tevent.so
50}
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080051
Brad Bishop26bdd442019-08-16 17:08:17 -040052PACKAGES += "python3-tevent"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080053
Brad Bishop26bdd442019-08-16 17:08:17 -040054RPROVIDES_${PN}-dbg += "python3-tevent-dbg"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080055
Brad Bishop26bdd442019-08-16 17:08:17 -040056FILES_python3-tevent = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/*"
57
58INSANE_SKIP_${MLPREFIX}python3-tevent = "dev-so"