blob: 6686a814fdce41ec3631522796715acf6d9fb8cb [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Network benchmark tool"
2DESCRIPTION = "\
3iperf is a tool for active measurements of the maximum achievable bandwidth \
4on IP networks. It supports tuning of various parameters related to timing, \
5protocols, and buffers. For each test it reports the bandwidth, loss, and \
6other parameters."
7HOMEPAGE = "http://software.es.net/iperf/"
8SECTION = "console/network"
9BUGTRACKER = "https://github.com/esnet/iperf/issues"
10AUTHOR = "ESNET <info@es.net>, Lawrence Berkeley National Laboratory <websupport@lbl.gov>"
11LICENSE = "BSD"
Brad Bishop26bdd442019-08-16 17:08:17 -040012LIC_FILES_CHKSUM = "file://LICENSE;md5=f9088fe7ffdccd042f7645f1012d7f70"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013
14DEPENDS = "openssl"
15
16SRC_URI = "git://github.com/esnet/iperf.git \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080017 file://0002-Remove-pg-from-profile_CFLAGS.patch \
18 "
19
Brad Bishop26bdd442019-08-16 17:08:17 -040020SRCREV = "dfcea9f6a09ead01089a3c9d20c7032f2c0af2c1"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080021
22S = "${WORKDIR}/git"
23
24inherit autotools
25
26PACKAGECONFIG[lksctp] = "ac_cv_header_netinet_sctp_h=yes,ac_cv_header_netinet_sctp_h=no,lksctp-tools"
27
28CFLAGS += "-D_GNU_SOURCE"
29
30EXTRA_OECONF = "--with-openssl=${RECIPE_SYSROOT}${prefix}"
31
32BBCLASSEXTEND = "native"