blob: 8c49b4674f9ed3916381129ecbdb8e71c107cac2 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Small collection of benchmarks for storage I/O"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b529aaa6a0c50f15d29f89609b5c22f3"
4
Brad Bishop26bdd442019-08-16 17:08:17 -04005SRCREV = "3b9eef2259a70f412ab02fbe6b3a4d313d09c38a"
6PV = "3.5"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08007SRC_URI = "git://github.com/Algodev-github/S.git;protocol=https;branch=master"
8
9S = "${WORKDIR}/git"
10
11# installing in /opt/S-suite since the package has
12# dependencies to the directory structure.
13do_install() {
14 install -d ${D}/opt/S-suite
15 for i in $(find ${S}/* -type d); do
16 install -d ${D}/opt/S-suite/$(basename $i)
17 install -m0755 -p ${S}/$(basename $i)/* ${D}/opt/S-suite/$(basename $i)
18 done
19
Brad Bishop19323692019-04-05 15:28:33 -040020 install -m0755 ${S}/def_config.sh ${D}/opt/S-suite
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080021 install -m0755 ${S}/config_params.sh ${D}/opt/S-suite
Brad Bishop19323692019-04-05 15:28:33 -040022 install -m0755 ${S}/process_config.sh ${D}/opt/S-suite
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080023}
24
Brad Bishop19323692019-04-05 15:28:33 -040025RDEPENDS_${PN} = "bash bc coreutils gawk g++ gcc fio libaio libaio-dev sysstat \
26 git"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080027
28FILES_${PN} = "/opt/S-suite/"
29
30# added to INSANE_SKIP since s-suite have an runtime
31# dependency (RDEPENDS) on libaio-dev.
32INSANE_SKIP_${PN} += "dev-deps"